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Server Hardware Planning 
 Lab 1 

Objectives 
After completing this lab, you should be able to: 

 Use the resources discussed in the previous modules to select the appropriate 
server solution for your cluster implementation.  

 Calculate the physical requirements for new cluster server nodes needed by 
an organization.  

 Determine which Compaq ProLiant servers meet the hardware requirements 
for the cluster to be constructed.  

 
 Note 

The hardware-planning chart in this section is a sample. It is intended to teach 
a process, not to provide specific information about application sizing. Some 
of the values that have been put in the chart are not necessarily accurate. 

 

Requirements 
There are no additional hardware or software requirements for this lab. 
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Exercise 1 — Scenario 
Your Management Information Systems (MIS) director has asked you to provide a 
clustered solution for the company’s mission-critical data. The solution must 
include a recommendation for Compaq ProLiant servers, storage arrays, and 
interconnections needed. Using the ProLiant server information from the student 
guide, determine which servers meet the hardware requirements for the clustered 
applications.  

Take the following information into account as you plan:  

 Your company currently has 375 employees. 

 Staffing could increase by as much as 30% over the next two years. 

 Email is mission-critical to the corporation. 

 Message traffic tends to contain large attachments. 

 The server room has a limited amount of floor space available. 

 Additional hard disk space must be available for management applications 
and utilities that you will need. 

Optimal Boot Partition size is calculated by adding the size of the boot partition 
(minimum 75MB) to the amount of server memory (for example 128MB); this 
equals 203MB as the minimum boot partition.  

The disk must also have enough available space outside the boot partition to 
accommodate the SYS volume. A large number of NetWare products are installed 
on the SYS volume, so you must have enough available disk space to 
accommodate NetWare and the products to be installed. 
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Exercise 2 — Capacity Planning 
Answer each of the following questions and fill in the hardware planning 
worksheet. Decide which server or servers meet your hardware needs. Use the 
notes column to list relevant information such as a formula or application name. 

1. Approximate amount of disk space needed by NetWare 6 and NCS. 

............................................................................................................................  

2. How much memory does NetWare 6 need? 

............................................................................................................................  

3. What applications will be on the server? 

............................................................................................................................  
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Hardware Planning Worksheet — Server Section 
 Disk Space (min) Memory Usage (min) Notes 
Boot partition 100MB local storage N/A  

 
NetWare 6 and NCS 1GB local storage 128MB  

 
Application 1 
(GroupWise) 

500MB local storage 128MB  
 

Application 2 
(Oracle8) 

1GB local storage 128MB  
 

Application 3 
(Netscape Server) 

500MB local storage 64MB  
 

Management tools 500MB local storage 64MB  
 

Total    
 

 
 
 Note 

Some applications consume local and shared storage. This lab is focused on 
local storage needs. 
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Shared Storage Hardware Planning 
Module 2 Lab 

Objectives 
After completing this lab, you should be able to: 

 Plan an appropriate external storage solution for the cluster. 

 Determine how much storage is necessary for business applications and data 
volumes. 

 Determine what RAID level is desired for fault tolerance. 

 Calculate the amount of storage necessary to support the desired RAID level. 

Requirements 
There are no additional hardware or software requirements for this lab. 
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Exercise — Scenario 
A possible solution to the problem posed in Lab 1, Server Hardware Planning, is 
the Compaq ProLiant DL380 Generation 2 (G2). This server supports more than 
109.2GB of internal storage, and more than 1GB of memory.  

Your Management Information Services (MIS) director has accepted the ProLiant 
DL380 G2 server solution and wants to add shared storage. Answer the following 
questions to help determine the appropriate storage array for your solution. 

1. What type of RAID protection is needed? 

............................................................................................................................  

2. How much logical space is required for the GroupWise data on the shared 
storage array? Assume 40MB of data for each user. 

............................................................................................................................  

3. How much physical space do you need to provide sufficient logical space for 
GroupWise? 

............................................................................................................................  
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Configuring the Shared Storage System 
Lab 3 

Objectives 
In this lab, you will: 

 Configure the shared storage subsystem with appropriate RAID sets. 

 Establish disk partitions used for cluster resources. 

Requirements 
To complete this lab, you will need: 

 One or more of the following storage subsystems: 

• RA4100 (requires CPQONLIN.NLM) 

• Compaq Smart Array Cluster Storage (requires CPQONLIN.NLM) 

• RA/MA8000 or ESA/EMA12000 require StorageWorks Command 
Console (SWCC) or Command Line Interpreter (CLI) 

• CR3500 Shared SCSI Storage (requires CR3500 Array Configuration 
Utility) 

 Maintenance cable (for CR3500 and MA8000 only). 

 Compaq universal hard disk drives. 

 Fibre Channel host bus adapters (HBAs) (not necessary for packaged cluster 
solutions). 

 Fibre Channel Arbitrated Loop (FC-AL) or Fibre Channel Switched Fabric 
(FC-SW) interconnect components (not necessary for packaged cluster 
solutions). 
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Configuration 
Unless otherwise indicated by your instructor, the servers have been previously 
configured in the following manner: 

 NetWare 6 with Support Pack 1 

 Compaq Support Paq for Novell NetWare from the SmartStart and Support 
Software CD 5.3 or greater 

 CPQFC.HAM 2.52 or greater (Fibre Channel solutions only) 

 Non-redundant HA/N100 configuration (pre-wired for HA/N200 or 
HA/N500) 

 The appropriate utilities either have been previously loaded on your systems 
or are available from your instructor. To configure the storage subsystem, use 
the appropriate utility for the selected storage enclosure to do the following: 

• Configure disk partitions to be used for cluster resources and shared 
volumes. For this purpose, assign a separate logical unit number (LUN) 
for each application resource. In actual practice, one of two approaches 
is taken. In both cases, each highly available resource will have its own 
disk space. 

• Create separate LUNs for each resource using the appropriate 
configuration utility. This is the approach that will be used in this 
course. Also, this approach would be used if Selective Storage 
Presentation (SSP) were deployed. 

 
 Note 

SSP will not be used in this lab. 
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You will be performing the following operations: 

 Create specified LUNs for later use with Novell Storage Services (NSS) 
partitioning. The partitions will be used later to create highly available 
resources. 

 Allocate at least 15–25MB of free space to be used for the cluster services 
partition.  

• The cluster services partition is used by Novell Cluster Services to 
implement a quorum arbitration scheme. In the quorum arbitration 
scheme, each server writes a status signature to a disk segment reserved 
for that purpose. If the cluster-interconnect heartbeat for a server is 
delayed because of heavy network traffic, the other cluster servers check 
the quorum status signature periodically to determine whether that 
server is operational. 

• The Novell Cluster Services installation procedure automatically 
allocates one cylinder on one drive of the shared storage for the cluster 
services partition.  

 
 Note 

The previous requirement for the SBD partition was 10–25MB. However, 
more space is required for drives that are larger than 10GB. For a practical 
application, reserve at least 15MB for currently shipping drives which are no 
smaller than 18GB. 
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When configuring the storage subsystem, consider the following: 

 For added fault tolerance, you can allocate an additional 15–25MB of free 
space for a redundant cluster services partition. 

 
 Note 

It is not necessary to carve out separate LUNs for the SBD. It is done in this 
lab as an exercise to demonstrate one method of deploying the solution. 

 

 Allocate additional partitions for future use. 

 Select appropriate RAID levels and hot spares. Use RAID 1 or RAID 5 for 
fault tolerance in shared storage. 

The following diagram shows an example of shared storage allocation. 
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Shared Storage Allocation Example 
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Exercise — Creating Logical Drives 
To create new logical drives: 

1. Shut down and power off all cluster server nodes. 
 

! Important 
If using a Fibre Channel configuration, there are two Fibre Channel 
interconnects. Do not alter their power configuration at this time. One 
interconnect should remain powered off so that the cluster can begin in a base 
configuration. 

2. Power on the storage subsystem if it is not already powered on. Wait for it to 
fully initialize. 

3. Power on the cluster server that contains the master replica of the Novell 
eDirectory Service (NDS) tree (Node 1). After you have configured the 
storage array, you can power on each of the other servers in the cluster one at 
a time and ensure that each server is capable of recognizing the newly 
configured storage. 

 
 Note 

If you are unsure as to which server contains the Master NDS Replica, use the 
NDSMGR32 utility, ConsoleOne, or Remote Manager to verify. 

 
4. Use the appropriate storage array configuration utility to configure the 

storage arrays with the following LUNs. 
 
Resource Use Approximate Logical 

Drive Size (MB) 
Logical Drive 1 20 
Logical Drive 2 20 
Logical Drive 3 (Remaining Space) 4096 or greater 
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If you are unfamiliar with the procedures for creating arrays and logical drives 
with your assigned storage system, refer to Lab Appendices A through C for more 
detailed information. The material in the appendices is provided for reference only. 
The exact procedures will not necessarily match requirements for this exercise. 

The following table outlines the available types of storage resources and their 
corresponding array configuration utilities. 
 
Compaq 
Storage 
Array 

 
 
Driver 

Array 
Configuration 
Utility 

 
 
Default Utility Location 

CR3500 CPQSCSI.HAM CR3500 Array 
Configuration Utility 

SmartStart and Support Software CD 
in the CR3500 directory 

Smart Array 
Cluster 
Storage 
Controller 

CPQRAID.HAM CPQONLIN.NLM or 
offline Array 
Configuration Utility 

Compaq Smart Array Cluster 
Storage Support Software CD or 
SmartStart and Support Software CD 

RA4x00 CPQFC.HAM CPQONLIN.NLM or 
offline Array 
Configuration Utility 

SmartStart and Support Software CD 

RA/MA8000 
or ESA/ 
EMA12000 

CPQFC.HAM CLI or SWCC ACS v8.5 or 8.6 for the HSG80 
Controller for CLI or the RA/MA8000; 
ESA/EMA12000 Fibre Solution 
Software v8.5B for Novell NetWare 
platform kit or later 
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Installing SANworks Secure Path by Compaq 
Without Clustering 

Lab 4 

Objectives 
After completing this lab, you should be able to: 

 Create Redundant Fibre Channel I/O links. 

 Inject Simulated Hardware Failures 

 Install and configure Secure Path for NetWare host software 

 Install the Secure Path Manager 

 Test Secure Path software and compare the raw multipath driver functionality 
to using the Secure Path for NetWare Utility. 

Requirements 
To complete this lab, you will need: 

 Redundant Fibre Channel hardware. 

 Multipath capable driver support. 

 SANworks Secure Path for NetWare 3.0a or SANworks Secure Path for 
NetWare for the RA4100 by Compaq. 

 RA4000 controller firmware 2.58 or later. 

 ACS 8.5F or 8.6F (if using HSG80 controller). 
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Configuration 
For the purpose of this lab, redundant hardware has already been preinstalled in 
your cluster servers. However, your backup Fibre Channel Arbitrated Loop (FC-
AL) hub, switch, or switched fabric is not currently active because there is no 
power to the secondary Fibre Channel interconnect device.  
 
 Note 

This lab is not applicable if you are clustering with the Compaq packaged 
cluster solutions, CL380 or the ProLiant DL380 G2 Packaged Cluster 
Solution. 

 
Use the Compaq Array Configuration Utility (ACU), the Command Line 
Interpreter (CLI), or the StorageWorks Command Console (SWCC) to verify: 

 Firmware revision 

 Redundant configuration with one controller active and the other in standby 
or active mode 

 
 Note 

Active/active controller modes can only be achieved with HSG80 controllers. 
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Exercise 1 — Enabling Redundant Configuration Using 
Multipath Driver Support 

1. Apply power to the redundant Fibre Channel interconnect. 

Within 6 to10 minutes the Compaq multipath CPQFC driver will recognize 
that the secondary path is active, and it will instruct the standby HBA to 
ignite its lasers. 

2. After a few minutes, switch to CPQONLIN (if using the RA4x00) and verify 
that one HBA is connected to an active controller and the other is connected 
to a controller in standby mode. 

3. What message indicates that an HBA is connected to an active controller? 

............................................................................................................................  

............................................................................................................................  
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Exercise 2 — Injecting Simulated Hardware Failures 
1. Unplug a Fibre Channel cable from the active controller – RA4000 Controller 

(Controller 0) or the top HSG80. 

2. Use the CPQONLIN, CLI, or SWCC utilities to determine if the storage array 
is still accessible. If it is, you have successfully introduced redundant 
components to make your storage system more highly available. This 
demonstrates the ability of the multipath driver to fail over from one path to 
another in the event of a hardware failure. 

3. Repair the broken Fibre Channel segment by plugging the Fibre Channel 
cable back in. 
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Exercise 3 — Installing and Configuring Secure Path for 
NetWare Host Software 

The Secure Path software is made up of the Novell NetWare Secure Path Agent 
and the CPQFC.HAM driver running at the server. The Secure Path Manager 
(SPM) runs on a remote Microsoft Windows NT or Windows 2000 client.  
 

! Important 
Each server accessing the shared storage must have Secure Path installed to 
ensure proper operation of the utility. 

 
In this exercise, you will be installing SANworks Secure Path for NetWare on 
each of the servers connected to the shared storage system. Ensure that the targeted 
systems have at least two host bus adapters (HBAs) installed and that they are 
powered up.  
 

! Important 
The SANworks Secure Path for NetWare host software must be installed 
before the SPM client software is installed because the client needs an agent to 
contact. 

 

Configuring the Server HOSTS File 
The HOSTS file must be edited to add the network host names and client names to 
all servers and clients that will be using Secure Path. This enables client lookup for 
authorization to access the Secure Path hosts through the agent software.  

1. Use the local server text editor EDIT.NLM to modify the server HOSTS file. 
From the server command console, enter EDIT SYS:ETC/HOSTS. 

2. Add the client name and IP address and save the HOSTS file to activate it. 

3. Repeat steps 1 through 2 for the other server nodes. 
 
 Note 

Although not used in this lab, DNS can be used instead of the HOSTS file. 
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Installing SANworks Secure Path 
1. Starting with Node1, insert the Secure Path CD and enter the NetWare 

console command CDROM. After the CD has been mounted, issue the Volume 
command. The CD should have a volume label of NWSPV30. If this is not 
visible, mount the volume by issuing the command Mount NWSPV30. 

 
 Note 

If the volume title is different for the Secure Path CD provided to you, use the 
appropriate volume label. 

 

 
 

 



Installing SANworks Secure Path by Compaq Without Clustering 

Rev. 2.11 L4 – 7 

 
 

2. Load NWCONFIG and select Product Options. Use F3 to specify the 
installation path of NWSPV30:\NETWARE. The screen will switch to the 
Secure Path installation program. That program will check the HAM and 
other drivers, and then start installing files. 

 
 Note 

Your instructor might have previously installed the appropriate HAM driver. If 
so, a brief message indicating that the current driver is acceptable will display. 
If the HAM driver needs to be upgraded, the new driver will be copied to the 
appropriate partitions. You will need to unload the old driver and reload the 
updated driver. 

 
3. Exit the Product Options screen when the installation is complete. 
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4. The agent file CPQSPAGT.NLM is loaded. If it does not automatically load, 
then manually load CPQSPAGT.NLM. Move to the Secure Path V3.0 
NetWare Loadable Module screen which will have the following options 
form the Main Menu: 

• Agent Administration 

• Client Administration 

• Storage Subsystems 

• Stop Agent 

5. The installation for the server is now complete. Select Agent Administration 
→ Change Password to set a password that authorizes remote stations to 
access this unit. Use the password “Compaq.” 

6. Escape out and ensure the following: 

• Load Distribution is DISABLED 

• Path Verification is ENABLED 

• Auto Failback is ENABLED 
 
 Note 

Auto Failback functions for a failed data path and not a failed controller. 
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7. Select Client Administration → Add a Client to add all client machines that 
need access to SPM. Enter client name and IP address in the following space: 

............................................................................................................................  

............................................................................................................................  

 

 Note 
This entry, along with the password entry, gives the client access to SPM. This 
entry is case sensitive and must match the client’s HOSTS file entry.  
Any changes to the SP Agent will require that the NLM be stopped and 
restarted for the changes to become active. 

 
8. Verify that the entry to load CPQSPAGT.NLM has been placed into the 

AUTOEXEC.NCF file. 

9. Repeat steps 1 through 8 for the other server nodes. 
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Exercise 4 — Installing the Secure Path Manager 
The Secure Path Manager (SPM) is deployed on a Windows NT or Windows 2000 
client to monitor and manage a Secure Path environment. SPM displays 
information about the state of RAID storage systems and I/O paths configured for 
high-availability storage access. The SPM sets various properties, policies, and 
modes associated with a managed storage profile. SPM will automatically detect 
and indicate path failures as well as provide the capability to move RAID array 
storagesets across controller pairs. 

Installing Client Software 
1. Modify the client’s local HOSTS file so that it includes all the node names in 

the cluster. The HOSTS file is located in the folder of path: 
winnt/system32/drivers/etc for Windows NT and Windows 2000. 

2. From the Secure Path/Windows folder, select Setup → Yes → Next → Yes → 
Next → Next to select the default path of: 
C:\Program Files\Compaq\SecurePath 

 
 

3. At the Choose Component to install screen, select SecurePath Client and 
click Next → Next → Next → Finish. 

 

! Important 
You must select SecurePath Client and not SecurePath Client and Server. The 
latter option is not used for the NetWare environment. The screen shot shows 
the default selection. 
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Configuring SPM Software 
1. Launch SPM by clicking its icon. 

 
 

2. Define the SPM Storage Profile in the Nodes screen by entering each of the 
nodes names with the syntax of ServerName. This syntax reflects the node 
name and cluster name separated by a hyphen. 

 

! Important 
Because SPM uses the hyphen to distinguish between node (Host) name and 
cluster name, hyphens must not be used in node names. 

 
3. Enter a unique name for the profile and save it. 

4. Specify the same password that you set on each of your server nodes with 
Agent Administration and save it. The password should be “Compaq.” 

5. After setting up and saving your profile, log in to SPM. 
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Managing Storagesets and Paths, and Monitoring Host Connections 
After successfully logging in with the SPM, you should see a server icon 
representing each of the server nodes. The node name will be on top of the icon.  

SPM monitors connection status for each active host that is a member of the 
current storage profile. SPM indicates a loss of connection to a host with a red 
“X.” This loss could be because the node is down, or because the Secure Path 
Agent is no longer running on that node. 

From the left pane of the screen, click a storage system and expand the listing of 
LUNs under that controller. Right-clicking to: 

• Move a storageset from one controller to the other. 

• Make a path Alternate. 

• Make a path Preferred. 

• Change the Preferred path. 

• Make a path Offline. 

• Make a path Online. 

• Verify a path. 

• Repair a path (manual fail back). 
 
 Note 

Not all features are available for all types of controllers. For the RA4000 array 
controller, if you move one disk from one controller to the other, all the disks 
will move because the controllers are always either in active or standby modes, 
but never active/active. 
For the HSG80 controllers, dragging disk devices between the two paths 
enables load balancing for each controller path. Remember to change the 
associated Preferred path on the HSG80 controller when you do this (for 
instance, SET D1 PREF = OTHER). Otherwise, the next time the server is 
restarted, the previous Preferred path unit setting will take precedence and 
place your disk back in its original path. 

 
How many controllers can you see and how many devices are attached to each 
controller? 

............................................................................................................................  
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Exercise 5 — Testing the Secure Path Software 
1. Unplug the Fibre Channel cable connected to the HBA, which is connected to 

the active controller of the shared storage system. The SPM graphical user 
interface (GUI) shows that the LUNs have now been failed over to the 
alternate controller. 

2. Repair the broken Fibre Channel segment by plugging the cable back in. 
With Auto Fail Back enabled, the LUNs should fail back to the other 
controller and HBA. 
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Installing Novell Cluster Services 
Lab 5 

Objectives 
After completing this lab, you should be able to: 

 Prepare for a Novell Cluster Services (NCS) Installation 

 Install NCS 1.6 

Requirements 
To complete this lab, you will need: 

 NWDEPLOY utility from NetWare 6 CD. 

 Novell Client32 software deployed on client to execute NWDEPLOY. 

 Minimum of two NetWare servers with minimum 256MB of memory each 
(512MB recommended for failing over multiple applications to the same 
server). 

 Servers should be pre-configured with drivers from SmartStart 5.3 or later. 

 NetWare 6 running on each server and all servers are in the same eDirector 
tree. 

 At least one local disk device for SYS: volume on each server. 

 Shared storage configured with RAID 1 or 5. 

 15–25MB of free space for the cluster partition. 

 Pre-wired Fibre Channel storage hubs or switches. 

 All servers are networked, configured with IP, and within the same IP subnet. 

 Documented IP addresses for the cluster and each of the highly available 
resources. 
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Exercise 1 — Preparing for NCS Installation 
Before installing NCS, have no Novell eDirectory Services (NDS) or time 
synchronization errors present. To achieve this goal, execute DSREPAIR on each 
of the nodes until there are no errors present. 

1. At server command of Node1 console enter DSREPAIR → Unattended full 
repair.  

2. After the repairs are complete, note how many errors are present. Press Enter 
to view the log file. Press Esc to log out of the log file editor.  

3. If there are still errors present, repeat steps 1 and 2. If there are no errors, 
proceed to step 4. 

4. Repeat steps 1 through 3 for the remaining server nodes. 

5. When all nodes are error free, proceed to Exercise 2. 
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Exercise 2 — Installing NCS 
The NCS installation program directs you through the steps required to install the 
NCS software on the cluster servers. To run the NCS installation program: 

1. If you have not already done so, log in from the client workstation with 
administrator privileges. 

 
 Note 

All admin accounts have the following assigned parameters: 
 Tree = CPQ 

 Context = NCS 

 Password = compaq 
 
2. Insert the NetWare Operating System CD in the CD-ROM drive and locate 

the NetWare Deployment Manager program (NWDEPLOY.EXE) in the root 
directory of the CD or locate the NWDEPLOY utility in the ClassPaq folder. 

3. Run NWDEPLOY.EXE. The first screen of the NetWare Deployment 
Manager displays.  
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4. Double-click the Post-Installation Tasks folder. 
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5. Click Install or Upgrade a Novell Cluster. The Welcome screen displays. 

 
 

6. Click Next. The NCS Action screen displays. 

 

 
 

7. Select Create a new cluster. 
 
 Note 

The Skip the file copy option can be used if NCS files have already been 
copied to cluster nodes. Otherwise, do not select this option. This option is 
enabled by default because the cluster files are copied to NetWare 6 servers 
during installation of the operating system. 
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8. Click Next. The NCS Cluster Selection screen displays. 

 
 

9. Enter the following cluster object properties: 

• Cluster Object Name: Cluster1 

• Directory Services Tree: CPQ 

• Directory Services Context: NCS 

After this step, the NDS Schema is extended with the new cluster container object. 

10. Click Next. The NCS Cluster Node Modification screen displays. 

 
 



Installing Novell Cluster Services 

Rev. 2.11 L5 – 7 

11. On the NCS Cluster Node Modification screen, use one of the following 
methods to specify the Node1 and Node2 servers that will form the cluster: 

• For each server, type the server name in the NetWare Server field and 
click Add to Cluster. 

• Click the browse icon next to the NetWare Server field to open a 
browser window similar to the following. Select one or more servers in 
the right-hand pane and click Add. The added servers displays in the 
Selected Items field at the bottom of the screen. Click OK. 

 
 
 
 Note 

NCS 1.6 supports the selection of multiple servers for addition to the cluster. 
 

NCS automatically detects the IP address of the server. This IP address will be 
used for the cluster interconnect. 
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If the server has more than one IP address, the following window displays, 
asking you to select an IP address. 

 
 

If this window displays, select the correct IP address and click OK. You can 
select either the same IP address used for the public LAN link or a different IP 
address for a dedicated cluster interconnect. You will only have one IP 
Address from which to select in this lab. 

 
 Note 

All cluster IP addresses must be on the same subnet. 
 
 



Installing Novell Cluster Services 

Rev. 2.11 L5 – 9 

The new server is added to the NetWare Servers in cluster list on the NCS 
Cluster Node Modification screen. The list also shows the IP address of each 
server. 

 
 

12. If all cluster nodes have not been selected, repeat step 11 for each node to be 
added to the cluster.  

13. Click Next when you have added all servers. The Cluster IP Address 
Selection screen displays. 
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14. Enter the cluster IP address 172.20.100.200. This address will be the Master 
Cluster IP Address and is unique for each cluster in the tree. 

 
 Note 

The cluster IP address is separate from the server IP addresses and is required 
for certain application programs to get cluster alerts. NetWare Remote 
Manager also requires a cluster IP address. 

 

The cluster IP address is bound to the master node and remains with the master 
node regardless of which server is the master node. 

15. Click Next. The NCS Shared Media Selection screen displays. Use this screen 
to allocate the cluster services partition. 

 
 
 
 Note 

The NCS installation procedure automatically allocates at least 15-25 MB of 
free space to be used for the cluster services partition. The cluster services 
partition is used by NCS on all cluster servers to implement a quorum 
arbitration scheme. In the quorum arbitration scheme, each server writes a 
status signature to a disk segment reserved for that purpose. If the cluster 
interconnect heartbeat for a server is delayed because of heavy network traffic, 
then the quorum status signature is checked periodically by the other cluster 
servers to determine whether that server is operational. 
 
For added fault tolerance, you can allocate an additional 15–25MB of free 
space for a redundant cluster services partition. 
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16. On the NCS Shared Media Selection screen: 

a. Select Yes next to “Does the cluster have shared media?” 

b. For greater fault tolerance, select the option to mirror the cluster 
services partition.  

c. From the first pull-down list, select the storage device for the shared 
media. 

d. If you selected the option to mirror the cluster services partition, select 
from the second pull-down list the device where the mirror partition is 
to be allocated. 

 
 Note 

If no shared media is detected, check all shared storage connections. Ensure 
that the desired partitions are free of any previous data.  

 
17. Click Next. The Start Clustering screen displays. 

 
 

18. Select the option to Start clustering on newly added or upgraded servers after 
installation.  
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19. Click Next. If more than two nodes are to be installed, the Licenses screen 
displays. For a 2-node cluster, this screen does not display since NetWare 6 
includes licenses for a 2-node cluster. No more than two licenses are installed 
in this lab, so this screen will not display. 

 
 

20. When the Summary screen displays, click Finish. 

 
 

The Install program creates a new cluster and configures NCS and the licenses you 
specified on the cluster servers. 

This completes the NCS installation procedure. NCS will start automatically. 
Select either View or Close for the Readme file option. If View is selected, 
remember to close it after viewing the document. 
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21. The NWDEPLOY screen displays. Exit NWDEPLOY by selecting Cancel → 
Yes. 

When NCS is started, the following server console screen displays, showing 
the nodes in the cluster and indicating that the cluster is active. 

 
 

22. Ensure that the client is logged in and run ConsoleOne from the following 
directory: 

sys:public\mgmt\consoleone\1.2\bin\consoleone.exe 
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Using Novell ConsoleOne to 
Manage Novell Cluster Services 

Lab 6 

Objectives 
After completing this lab, In this lab, you should be able to: 

 Use ConsoleOne views to manage Novell Cluster Services (NCS). 

 Configure cluster properties using ConsoleOne. 

 View the Split-Brain Detection Process. 

 Change the cluster Master IP address 

Requirements 
To complete this lab, you will need ConsoleOne 1.3.2 or later files with the NCS 
snapin. 
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Configuration 
ConsoleOne is a Java-based graphical user interface (GUI) used to monitor and 
manage NetWare 6 and NCS 1.6. It allows remote management of the cluster from 
any workstation that has access to Novell eDirectory Services (NDS). ConsoleOne 
features an HTML cluster-wide event log for node and resource status. 

You can install ConsoleOne on any client workstation (or on multiple 
workstations).  

Compaq recommends that the client machine used to manage the cluster be at least 
300MHz or higher and have at least 90MB of memory. 
 
 Note 

You can also run ConsoleOne on a cluster server from the X Server Graphical 
Console. ConsoleOne, with the cluster snapin, is automatically installed with 
NetWare 6 servers. 

 

Unless otherwise indicated by your instructor, for the purposes of this lab exercise, 
ConsoleOne 1.3.2 or later has already been installed on your lab workstation along 
with the NCS snapin. 
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Exercise 1 – Examine ConsoleOne Views 
1. Start ConsoleOne by double-clicking the ConsoleOne icon on the Windows 

desktop. This displays the ConsoleOne main screen; where all the NDS 
objects in the tree can be revealed. 

 
 

ConsoleOne provides three views from which you can manage your cluster: 
Cluster State view, Console view, and Partition and Replica view.  
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2. To open a view, select the cluster object in the directory tree in the left-hand 
pane. The Console view will display by default.  

 
 Note 

The cluster object is the one with three attached red balls to represent NCS. 
 

 
 

The Console view shows the cluster servers, resources, and templates. From 
this screen, you can view and change cluster and resource properties, and 
create clustered volumes. The following is an example of the Console view. 
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3. Select View → Cluster State View. 

The Cluster State view displays information about the status of servers and 
resources. It shows you which volumes and services are running on each server 
in the cluster as well as the state (Offline, Running, and so on) of the volume 
or service. The following is an example of the Cluster State view. 

 
 

 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6  

L6 – 6 Rev. 2.11 

4. Select the CPQ object from the left pane. 

5. Select View → Partition and Replica View. 

The Partition and Replica view shows the state of the replicas. 
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Exercise 2 — Configuring Cluster Properties 
In this exercise, use ConsoleOne to set NCS cluster membership and 
communication properties. 

Configuring Cluster Membership Properties 
Because your cluster contains only two nodes, and you will be restarting both 
nodes often during the remaining labs, increasing the timeout period will allow 
enough time for the second node to restart after the first node has been started. 
This prevents potential errors during the remaining labs. 

1. In the directory tree of the left pane, right-click the cluster object and select 
Properties. This will open the Cluster Object property sheet. 

2. Click the Quorum tab. 

3. Verify that the Membership property is set to 2, which is the number of nodes 
that must be running in the cluster before resources will start to load. 

4. The Timeout property configures the amount of time to wait for the number 
of servers defined in the membership field to be up and running. Set this to 
two minutes (120 seconds). 

5. Click OK. To activate the changes, restart all nodes. 
 
 Note 

The Timeout Trigger is one property that forces a node reboot for a changed 
value to take effect. 

 
6. After all cluster nodes have been restarted, proceed to the Configuring 

Cluster Communication Properties section. 
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Configuring Cluster Communication Properties 
You have asked your network analyst to examine the network traffic on the LAN 
in which the cluster resides. The analyst reports that an unknown problem with the 
Ethernet switch through which the cluster is connected to the LAN is causing the 
switch to spontaneously reset itself periodically.  

The reset takes a maximum of 25 seconds to complete. Until this problem can be 
corrected, you need to configure your cluster to avoid failing over because of these 
periodic errors. 

1. Log back in and launch ConsoleOne. 

2. In the directory tree overview, right-click the cluster object and select 
Properties. 

3. Click the Protocol tab. 

4. Change one or more of the following properties to achieve the desired 
configuration: 

• Heartbeat — The amount of time between transmits for all nodes in the 
cluster except the master 

• Tolerance — The amount of time the master node gives all other nodes 
in the cluster to signal that they are alive 

• Master Watchdog — The amount of time between transmits for the 
master node in the cluster 

• Slave Watchdog — The amount of time the master node has to signal 
that it is alive 

Which properties did you change, and what values did you choose? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  
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Exercise 3 – View Split-Brain Detection Process 
This exercise shows the timing of the split-brain detection process.  

1. Switch to the Console screens for each of the two servers. 

2. Disconnect the network cable for Node2 at the Ethernet hub; then watch what 
happens at both server consoles. 

What message displays on the Node2 console? 

............................................................................................................................  

............................................................................................................................  

Approximately how long does it take before this message displays? 

............................................................................................................................  

3. On Node1, switch to the Cluster Monitor (CMON) screen and use the left and 
right arrow keys to highlight each node. Read the node information in the 
dialog box at the bottom of the screen. 

4. From the ConsoleOne Cluster State view, click the Event Log tab and note 
the Cluster Event log entries for Node2. 

5. Reconnect the LAN cable to Node2. 

6. At the abend screen on Node2, enter X. 

7. Restart the server by entering SERVER. 

8. Use CMON on Node1 to verify that Node2 has rejoined the cluster.  

9. At Node2, switch to the Console screen. 

10. After NetWare is running normally on Node2, power off Node2. 

11. Switch to the Logger screen of Node1 and read the console messages.  

12. Change to the CMON screen and note the states of the cluster nodes. 

13. Power on Node2. 

14. From the Node1 CMON screen, watch for a message indicating that Node2 
has rejoined the cluster. 

15. From the Cluster State view of ConsoleOne, verify that both cluster nodes are 
available to run clustered services. 
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Exercise 4 – Changing a Cluster Master IP Address 
The Cluster IP address is assigned when you install Novell Cluster Services. The 
Cluster IP address normally does need to be changed, but can be if needed.  

The default cluster port number is 7023, and is automatically assigned when the 
cluster is created. The cluster port number does not need to be changed unless a 
conflict is created by another resource using the same port number. If there is a 
port number conflict, change the Port number to any other value that does not 
cause a conflict. 

To view or edit the Cluster IP address and port number using 
ConsoleOne: 

 
1. Right click the cluster object. 
2. Select Properties. 
3. On the Cluster Object property page, select the Management tab. 
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To view or edit the Cluster IP address and Port number using 
NetWare Remote Manager: 

 
1. On the left column under the Clustering section, click Cluster Config. 

2. Select the Cluster object name. 

3. Click IP Address. 

Number+IP Address specifies the cluster node number and IP address for the 
selected node. If the cluster node number or IP address changes for the 
selected node, the new information is not automatically updated in 
eDirectory.  

4. Change the cluster Master IP address to 172.20.100.205 and click Apply to 
update the information in eDirectory. 
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Configuring NSS Shared Storage 
Lab 7 

Objectives 
After the installation of NCS, the shared storage must be configured. After 
completing this lab, you should be able to: 

  Create shared disk partitions. 

 Create NSS pools. 

 Create NSS volumes. 

 Manage storage with Novell Remote Manager (NRM) 

Requirements 
To complete this lab, you will need: 

 Available storage within the shared storage system. 

 Novell ConsoleOne 1.3.2 or Remote Manager utility. 

 
 
 Note 

It is a good practice to perform disk maintenance from a consistent server. In 
this lab, disk maintenance will be performed consistently from server Node1, 
unless otherwise specified. 
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Exercise 1 — Create Shared Disk Partitions with 
ConsoleOne 

1. Start ConsoleOne. 

 
 

2. On the main ConsoleOne screen, right-click the NDS tree where the cluster 
object resides and select Disk Management → Devices from the pop-up 
menu. 

 
 

3. Enter the NDS tree and context, and specify a server name. Then click OK. 
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4. On the Properties page, click the Media tab → Devices, and highlight the 
device on which the partition is to be created. This will be the largest 
available logical drive. Ensure that the Sharable for Clustering flag option is 
set. Then click OK.  

 
 Note 

If the OK button is grayed out, de-select the Sharable for Clustering flag 
option and then reselect it. 

 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

L7 – 4 Rev. 2.11 

 
 

5. Click the Media tab → Partitions. The Create a new partition screen displays.  

 
 

6. Click the New button and then select the device on which to create the 
partition. This should be the same device selected in step 4. 
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7. Ensure that the partition type is NSS. 

8. Enter a size of 10GB for the partition size.  

9. Enter a Label of MyPartition1 in the optional label field. 

10. If the Hot Fix and Mirror options are selected, deselect them. Deselecting one 
of them will automatically cause the other to be deselected. 

 
 Note 

The only reason that the Hot Fix and Mirror options are deselected here is 
because they are not needed in a Compaq hardware based RAID environment. 
Leaving them selected causes no problems or performance degradation. 

 

11. Click OK → Apply to create the partition.  

12. Repeat steps 6–11 to create the following partition: 

• Partition Name: MyPartition2 

• Partition Size: 2GB 

13. Close the Properties page and proceed to Exercise 2. 
 
 Note 

If sufficient disk space is not available, use smaller partition sizes. Do not 
make partition sizes smaller than 2GB for this lab.  

 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

L7 – 6 Rev. 2.11 

Exercise 2 – Create NSS Storage Pools with ConsoleOne 
The storage pools feature in NSS provides more flexibility in planning and 
configuring shared storage to work with NCS. Multiple cluster-enabled volumes 
can now be part of a single cluster resource, and volumes can dynamically grow as 
needed to take advantage of free disk space. 

Storage pools must be created before creating cluster-enabled volumes. 

To create a storage pool: 

1. On the management client, start ConsoleOne if it is not already running. On 
the ConsoleOne main screen, right-click the server object and choose Disk 
Management  → NSS Pools from the pop-up menu. 
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2. The NSS Disk Administration screen displays. 

 
 

3. Enter the NDS tree name, context name, and the name of the server through 
which you will access the shared storage. The Properties page displays. 

 
 

4. Click the Media tab → NSS Pools, and click New. The Create a New Pool 
screen displays. 
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5. Enter MYNSS_Pool in the Name field for the new storage pool. Leave the 
LSS Type field unchanged. ZLSS is the default pool type and should be the 
type used with NCS. Click Next. The Storage Information screen displays. 

 
 

6. Select a storage partition that is approximately 10GB to be used for the pool, 
then click Next. 
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The Attribute Information screen displays, showing the type and size of the pool 
you are creating. If necessary, you can go back and change these attributes. 

The Activate on Creation option is selected by default. This option causes the pool 
to be activated as soon as it is created. If you deselect this option, you will need to 
manually activate the pool later before it can be used. 

 
 

7. Click Finish. The storage pool is created and you are returned to the 
Properties page, which shows the pool just created (in this case, 
MyNSS_Pool). 
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8. Repeat steps 4–7 to create a pool with the following characteristics: 

• Pool Name: GroupWisePool 

• Pool Size: 2GB 

9. When completed, the following pool properties should be present. 

 
 

10. Close the Properties page and proceed to creating NSS Volumes on the pool 
for use by the cluster. 
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Exercise 3 – Create NSS Volumes with ConsoleOne 
You can create multiple volumes on NSS storage pools. To create an NSS volume: 

1. In ConsoleOne, access the Properties page of Node1. 

 
 

2. Click the Media tab  → NSS Logical Volumes.  
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3. Click New. The Create a New Logical Volume screen displays. 

 
 

4. Enter the name VOL1 for the new volume and click Next. The Storage 
Information screen displays. 

 

 
 

5. Highlight the storage pool where you want the volume to reside.  

6. Enter a maximum volume size of 2048MB in the Volume Quota (MB) field. 
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 Note 
In actual applications, either a fixed quota for the volume in the Volume Quota 
(MB) field or the Allow volume quota to grow to the pool size option would be 
selected. The quota is the maximum possible size of the volume. If you are 
creating more than one volume per pool, specify a quota for each volume 
rather than allowing the multiple volumes to grow to the pool size. 

 

7. Click Next. The Attribute Information screen displays, showing the attribute 
settings of the volume. If necessary, you can go back and change these 
attributes. Accept the default selections. 

 
 

8. Click Finish to create the volume. 
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9. When the volume is created, the Properties page shows the new volume and 
its attributes. 

 
 

10. This completes the procedure for creating an NSS volume. Repeat these steps 
until all of the following volumes are created. 
 
Resource Name Pool name 

Approximate Logical 
Drive Size (MB) 

VOL1 MYNSS_POOL 2048 
VOL2 MYNSS_POOL 2048 
GPW GROUPWISEPOOL Allow volume quota to 

grow to pool size 

 
11. After you have created NSS volumes, close the properties screen.  
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Exercise 4 – Managing Storage with Novell Remote 
Manager 

This exercise shows an alternative method to ConsoleOne for managing NSS 
storage. 

1. Access the console of the management PC. To launch Novell Remote 
Manager for Node2, open a web browser and enter the following URL: 
http://172.20.100.202:8008 or use an IP address provided by your instructor. 

2. Log in as admin with a password of compaq. 

 
 

3. From the left pane, select Manage Server → Volumes. 

4. To access the Server Disk Partition Operations screen, from the right pane, 
select Disk Partitions. 
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5. Next to the Free Disk Space line, select Create → Create a New Pool and 
Volume and specify the following parameters: 

• Pool Size: 3096 

• Pool Name: BigPool 

• Volume Name: BigVol  
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6. Select Create → OK → OK.  
 Note 

There is an option to Cluster Enable Pool. This option will not function 
properly unless NetWare 6 Support Pack 1 is installed. 

 

 
 

7. To mount the new volume, browse to the bottom of the Novell Remote 
Manager screen and locate the new volume. Select Mount Volume → OK.  

 Note 
The Allow volume quota to grow to pool size option has been selected by 
default for this volume. 

 
Cluster-enabled volumes for higher availability may now be created.  
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Creating Cluster-Enabled Volumes 
Lab 8 

Objectives 
After the shared storage is configured, highly available file storage resources can 
be created. After completing this lab, you should be able to: 

 Create cluster-enabled volumes. 

 Migrate cluster-enabled volumes. 

 Attach to cluster-enabled volumes. 

Requirements 
To complete this lab, you will need: 

 Previously configured shared storage. 

 Novell ConsoleOne 1.3.2 or Remote Manager utility. 

 

 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

L8 – 2 Rev. 2.11 

 Exercise 1 — Create Cluster-Enabled NSS Volume 
To cluster-enable a volume: 

1. On the ConsoleOne main screen, locate and select the cluster object. 

 
 

2. Click File → New → Cluster  → Cluster Volume.  
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 Note 
If the Cluster Volume option is grayed, ensure that the pools are active and that 
eDirectory is properly updated with the current NSS Pool information by 
selecting Properties →  Media → Update NDS for the MYNSS_Pool pool.  
Also, ensure that all volumes to be cluster-enabled are active and flagged as 
sharable for clustering. This is accomplished by selecting Media → NSS 
Logical Volumes. Then select a volume and the Properties tab for that volume 
and enable the Sharable for Clustering attribute. 

 
3. The New Cluster Volume screen will display. 
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4. Browse and select the NODE1_VOL1 volume on the shared disk system to 
cluster-enable. Click OK. 

 
 

5. Enter the IP address 172.20.100.11 for the VOL1 resource.  

6. Ensure the following are selected 

• Online Resource after Create option to cause the volume to 
automatically mount after it is created. 

• Define Additional Properties to set Start, Failover, and Failback modes. 
7.  Do not click Create at this time. 

By default, the name of the virtual server object is automatically created using the 
convention: 

Cluster Object Name_+Cluster Enabled Pool Name+_Server 
 

in all capitalized letters. Similarly, the cluster-enabled volume object is 
automatically created using the convention: 

Cluster Name_Volume Name 
 
 Note 

The cluster name for a cluster-enabled volume is not necessarily capitalized. 
 
Using NCS 1.6, these virtual cluster object names can be altered. This enables the 
administrator to assign names that: 

 Do not have potential conflicts with some DNS servers. 

 Are tailored to fit corporate naming conventions. 

 Are more easily referenced within script files or from console command line 
prompts. 
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 Note 
If you are cluster-enabling a volume in a pool that has already been cluster-
enabled, the virtual server object has already been created. In this case, you 
cannot change the virtual server object name. 

 

 
 

8. Change the virtual cluster object names to the following 

• Virtual Server Name: Virtual_Server1 

• Cluster Volume Name: Virtual_VOL1 

9. Click Create to create the cluster volume. 

What is the Cluster Resource IP Address? 

............................................................................................................................  

10. Review the Cluster Resource Load and Unload Scripts. 

11. Ensure the following Cluster Resource Policies: 

• Start Mode: Auto 

• Failover Mode: Auto 

• Failback Mode: Auto 

To which nodes is this virtual server resource currently assigned? 

............................................................................................................................  

............................................................................................................................  
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Which of the two nodes will have the primary responsibility of loading this 
resource? 

 Node1 

 Node2 

12. Click OK to close the properties screen. 

13. Notice that both the virtual server and the virtual volume objects now display 
in the eDirectory. 

 
 

The pool will automatically come online and activate. 

14. Select the cluster object. 
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15. Select View  → Cluster State View. 

16. Repeat steps 1–9 for the remaining cluster-enabled volumes. Use the 
following values. 

 

Volume 
Name 

Virtual Server 
Name 

Virtual 
Volume 
Name IP Address 

Failback 
Mode 

VOL1 Viirtual_Server1 Virtual_VOL1 172.20.100.11 AUTO 
VOL2 Viirtual_Server1 Virtual_VOL2 172.20.100.12 Disable 
BigVol Virtual_BigSvr Virtual_BigVOL 172.20.100.13 AUTO 
GPW Virtual_Mail Virtual_GRPW6 172.20.100.30 AUTO 

 
17. Can the VOL2 IP address be modified? If not, why? 

............................................................................................................................  

............................................................................................................................  

18. Is the failback mode modifiable for VOL2? If so, how is this different from 
the IP address? 

............................................................................................................................  

............................................................................................................................  

............................................................................................................................  



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

L8 – 8 Rev. 2.11 

 
 

19. In the right pane, how does the virtual server icon differ from the physical 
server icon? 

............................................................................................................................  

............................................................................................................................  

20. In the right pane, how do server cluster node icons differ from resource 
icons? 

............................................................................................................................  

............................................................................................................................  
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This completes the procedure to cluster enable a volume. The Cluster State view in 
ConsoleOne shows the storage pools and volumes that currently exist on the 
cluster. 
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Exercise 2 — Migrating Volumes 
In this exercise, you will migrate the cluster-enabled volume you created to the 
other node. This tests the cluster installation. During normal operations, this 
procedure can be used to dynamically reallocate volumes amongst the nodes in the 
cluster. 

1. Using the ConsoleOne Cluster State view, click the cluster resource name 
Virtual_Server1. Select the other node (Node2) and click Migrate. 

 
 

2. The Cluster State view will indicate that the volume migration was successful 
by ending in a Running state on Node2. 
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Exercise 3 – Attaching to the Cluster-Enabled Volume 
1. Use either the Microsoft Map Network Drive or the Novell Map Network 

Drive command to connect to  
\\cpq\ncs\virtual_vol1. 

2. Copy the entire c:\winnt\system32 directory to the VOL1. 
 
 Note 

There will eventually be a share violation since some files will be in use. The 
violation is acceptable. The point of this exercise is to place some files on to 
the share. 

 

3. Migrate the Virtual_Server1 resource back to Node1. 

4. Ensure that the volume’s files are still available by opening the previously 
established drive share. 

Was your mapping still in tact after the migration? 

............................................................................................................................  

 Note 
If there is a separate monitor attached to your cluster servers, you can view the 
failover process from the console. The node that owned the resource before 
migration will indicate that the IP address is being deleted, and that the volume 
is being deactivated. The node the resource is being failed over to will indicate 
that the volume is being activated, and the IP address for the resource is being 
added to the target node. 

 
The next step injects a failure while copying a file to the cluster-enabled volume.  

5. Copy the entire ClassPaq\GroupWise6 directory to VOL1 again. 

6. While the files copy, migrate the cluster resource using ConsoleOne. 

Observe that even though ownership of the virtual NCP server advertisement has 
been switched from one cluster node to another, the availability of the resource 
remains in tact.  
 
 Note 

Since Microsoft Win9x clients maintain file state information, the copy 
process would only momentarily be interrupted at the introduction of the fault. 
Windows NT or Windows 2000 clients do not maintain file state information, 
so at the introduction of a fault, they will halt their operation. They will 
reconnect to the file share, but the copy process will be aborted. 
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Establishing Storage Data Path Redundancy 
with SANworks Secure Path by Compaq 

Lab 9 

Objectives 
After completing this lab, you should be able to: 

 Create a Secure Path Manager (SPM)  

 Test the installation of Secure Path Software. 

Requirements 
To complete this lab, you will need: 

 Completion of Lab 4. 

 Redundant Fibre Channel hardware. 

 Multipath driver support. 

 SANworks Secure Path for NetWare v3.0 by Compaq. 

 Smart Fibre Array firmware 2.58 or later (if using the RA4x00). 

 ACS 8.5F or 8.6F (if using HSG80). 
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Configuration 
For the purposes of this workshop, redundant hardware has already been 
preinstalled into your cluster servers. However, your backup Fibre Channel 
interconnect is not currently active because there is no power to the secondary 
interconnect device.  

Use the Compaq Online Array Configuration Utility, Command Line Interpreter 
(CLI), or the StorageWorks Command Console (SWCC) to verify: 

 Firmware revision 

 Redundant configuration with one controller active and the other in standby 
or active mode 

 
 Note 

Active/active controller modes can only be achieved with HSG80 controllers. 
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Exercise 1 — Creating a Secure Path Manager Cluster 
Profile 

In this exercise, you will create a new profile to reflect the clustered environment. 

Configuring SPM Software 
1. Launch Secure Path Manager by clicking its icon. 

 
 

2. Define the new SPM Storage Profile in the Nodes screen by entering each 
node name with the syntax of: ServerName-ClusterName. This syntax 
reflects the node name and cluster name separated by a hyphen. 

 

! Important 
Because SPM uses the hyphen to distinguish between node name and cluster 
name, it is important that hyphens are not used in node names. 

 
3. Enter a unique name for the profile and save it. 

4. Specify the same password that you set on each of your server nodes with 
Agent Administration and save it. The password should be “Compaq.”  

5. After setting up and saving your profile, log on to SPM. 
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Exercise 2 — Testing the Secure Path Software 
1. Delete the GroupWise folder from the cluster-enabled volume.  

2. Re-copy the folder from the Management PC to the cluster-enabled share. 

3. While the files copy, unplug the power to the hub or switch connected to the 
active controller. 

Observe that the file continues to copy and that Novell Cluster Service (NCS) does 
not detect a failure. Therefore, NCS does not attempt to fail over the resource. The 
SPM graphical user interface (GUI) shows that the logical unit numbers (LUNs) 
have now been failed over to the alternate controller. 

4. Repair the broken Fibre Channel segment by plugging the power back in.  

5. With Auto Fail Back enabled, fail back the LUNs to the other controller. 
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Cluster-Enable and Test the DHCP Server 
Lab 10 

Objectives 
After completing this lab, you should be able to: 

 Configure DHCP using iManage. 

 Cluster-enable an existing DHCP server. 

 Test the effect on a Windows 2000 workstation of migrating the DHCP 
resource. 

Requirements 
To complete this lab you will need: 

 Existing NCS 1.6 cluster. 

 Access to the Nwdeploy utility. 
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Exercise 1 – Installing DHCP 

 
 

1. Launch NWDEPLOY and select Post Installation Tasks → Install NetWare 6 
products. 

 
 

2. From the Target Server screen, select Node1 → Next. 
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3. At the Login Dialog screen, enter the following information. 
  

Specify Login 
Information for Node1 Value 
User Name: admin 
User Password: compaq 
Tree: CPQ 
User Context: ncs 

 

 
 

4. At the Components screen, select Clear All.  
5. Select Novell DNS/DHCP Services → Next to validate the component 

selection. 
6. Select Finish at the Summary screen.  
7. Select Close to complete the installation.  
8. When execution returns to the NWDEPLOY screen, repeat steps 1–7 for 

Node2. Exit the NWDEPLOY utility when finished. 
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Exercise 2 – Configuring DHCP using iManage 
The DHCP server will be configured during this exercise on one of the server 
nodes. The DHCP configuration information will be read from the eDirectory for 
the other server nodes. 

1. Launch the browser at the management workstation. 

 
2. Access the NetWare 6 Welcome Page by entering the URL 

http://172.20.100.201 for Node1.  

3. From the left pane, select Open iManager to launch iManage. If there is an 
error opening the page, map directly to iManager by using the following 
URL: http://172.20.100.201:2200/eMFrame/iManager.html. 
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4. Log in to iManager, and from the left pane, select the DHCP Management → 

DNS/DHCP Scope Settings.  

 
5. Specify ncs as the context for both the DNS/DHCP Locator object and the 

Administrative scope. Select OK → OK. 

6. From the left pane, select DHCP Server Management → Create Server → 
OK.  

7. From the right pane, browse to locate Node1 and select Create → OK. 

8. From the left pane, select Subnet Pool Management → Create Subnet Pool 
→ OK. 
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9. In the right pane, specify the following information: 

• Subnet Pool Name: LabPool 

• Select eDirectory Context: ncs 

10. Select Create → OK. 

11. From the left pane, select Subnet Management → Create Subnet → OK to 
begin the process of creating a subnet. Specify the following information.  
Create Subnet Options Values 
Enter Subnet Name: Sub1 
Enter eDirectory Context: ncs 
Enter Subnet IP Address: 172.20.0.0 
Enter Subnet Mask: 255.255.0.0 
Select Default DHCP Server: Node1 

 
12. Select OK to acknowledge the creation of the subnet. 

13. From the left pane, select Address Range Management → Create Address 
Range → OK.  

14. Specify the subnet created in step 11, Sub1. 

15. Specify a range object name of Range1. 

16. Specify a range between 172.20.100.150 and 172.20.100.160, then select 
Create → OK. 

17. From the console screen of Node1 enter the command load DHCPSRVR –
D2. 

 
 Note 

The –D2 switch is used to enable the DHCP console screen. 
 
18. The new DHCP server can be started/stopped by selecting the DHCP Server 

Management section and selecting Start/Stop Server from the drop–down list. 

19. Select Node1 from the list. 

20. Select OK →  Start to load the service. Wait for the service to load. 

21. After the notification that the start of the service is complete, select OK.  
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Exercise 3 – Cluster-Enable the DHCP Server 
The DHCP lease information is stored within the eDirectory. For this reason a 
shared volume is not needed for a cluster-enabled DHCP server resource. The 
previously installed DHCP server will be cluster-enabled in this exercise. 

1. Open and authenticate to the NetWare Remote Manager using the IP address 
of https:\\172.20.100.201:8009. 

2. From the left panel under Clustering, select Cluster Config. 

3. In the right panel, scroll to the bottom and select New Cluster Resource → 
DHCP Server.  

4. Enter DHCP in the Resource Name text box. The DHCP Server is the name 
of the cluster resource template used to create the DHCP resource. 

5. Select the Define Additional Properties check box, then select Apply. 

6. Modify the Load script to edit the Cluster command with the following: 

• CLUSTER DHCP CN=NODE1.O=NCS.T=CPQ 

• DHCPSRVR –d2 

7. Select Apply to save the changes. 

8. At the console of Node1, ensure that the DHCPSRVR is not running by 
entering the command UNLOAD DHCPSRVR. 

9. Bring the DHCP resource online: 

a. In the left panel, select Cluster Management to display the Cluster 
Status view. The DHCP resource is now added to the Cluster Resource 
list with an “Offline” status message displayed. 

b. Select DHCP → Node1 → Online. 

c. From the refresh drop-down list, select 2 seconds → Begin Refresh. The 
Offline status message is replaced by “Loading” then “Running” 
messages. 
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Exercise 4 – Migrating the DHCP Resource 
The steps in this exercise are used to test the effect of the DHCP resource 
migration on a Windows 2000 workstation. 

1. At the Windows 2000 workstation, make sure the IP address for the 
workstation is selected automatically: 

a. Right-click My Network Places → Properties, 

b. Right-click Local Area Connection → Properties. 

c. Select Internet Protocol (TCP/IP) → Properties. 

d. Ensure that Obtain an IP address automatically is selected. 

e. Close the open dialogs by selecting OK. 

2. Close the Network and Dial-up Connections window. 

3. At the Windows 2000 workstation, select Start → Run → cmd to launch a 
command prompt. 

4. At the command prompt, enter IPCONFIG /RELEASE → IPCONFIG 
/RENEW. 

5. Enter IPCONFIG /ALL. Record the following: 

• IP Address: ________________ 

• DHCP Server: ______________ 

6. From the consoles of Node1 and Node2, access the Logger screen. 

7. From the NetWare Remote Manager at the Windows 2000 workstation, 
migrate the DHCP resource from Node1 to Node2 and begin Refresh every 2 
seconds. 

8. From the console of Node1, check the Logger screen for new messages. The 
Unload script commands for the DHCP cluster resource should terminate the 
DHCP server running on Node1.  

9. From the Windows 2000 command prompt, enter IPCONFIG /RELEASE 
after the migration is complete. Next, enter IPCONFIG /RENEW. 

10. At the command prompt, enter IPCONFIG /ALL and compare the IP 
addresses in the IP configuration information with those recorded in step 5. 

11. Close the command prompt by entering EXIT. 
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Clustering Novell GroupWise 6 
Lab 11 

Objectives 
After completing this lab, you should be able to: 

 Activate and mount Novell Storage Services (NSS) volumes. 

 Install Novell GroupWise 6 on each node of the cluster. 

 Configure the GroupWise home directory. 

 Modify the GroupWise NSS cluster-enabled volume resource to load 
GroupWise services. 

Requirements 
To complete this lab, you will need: 

 Novell GroupWise 6 CD-ROM or file repository. 

 Virtual IP address assigned to your GroupWise installation. 

 Cluster-enabled Virtual_GRPW6 volume that is started and running on 
Node1. 

 
 Note 

There are multiple ways to install GroupWise 6 within a clustered 
environment. The method used in this lab is only one such method and is not 
meant in any way to be the authoritative method for the installation of the 
product. 

 
 

 For more information on installing applications within an NCS environment, 
refer to the documentation of the vendor or visit: 
www.novell.com/documentation. 
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Exercise 1 — Mounting NSS Volumes 
Before mounting NSS volumes, keep in mind the following: 

 The Domain directory and the Post Office directory must be located on the 
shared storage volume. 

 The access mode for the Post Office is client/server only. 

 The Message Transfer Agent (MTA) links to the Post Office through a 
TCP/IP connection to the Post Office Agent (POA). 

 The POA and the MTA use the same IP address. 

 The Autoexec.NCF file should not be updated during the GroupWise Agent 
installation process because the loading and unloading of the mail services 
will be controlled by the Load/Unload script properties of the cluster. 

 The GroupWise Agent must be installed on all nodes of the cluster that can 
host GroupWise. 

 The POA and MTA startup files must be edited to reflect the correct path to 
the home directory. The path to the home directory follows the convention 
/home-NSSVol_name:\directory. For example, if your NSS volume name is 
GPW and your Post Office directory is podir, the correct home path is /home-
gpw\podir. This also applies to the MTA startup file. 
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At Node1, the Virtual_GRPW6 cluster-enabled volume is modified to load the 
GroupWise 6 MTA and POA agents.  
 
 Note 

The GroupWise Mail Server template will not be used in this exercise. This 
exercise uses a preferred method of installation offered by Novell Consulting 
Services and Novell engineering. 

 

 
 

1. Map a network drive G: to the Virtual_GRPW6 volume. The mapping should 
be done by browsing through the virtual server or using the full UNC path 
name, ensuring that the UNC path through the cluster-enabled volume is 
being used. This only has to be performed on a single node. 

2. Create a directory on the Virtual_GPRW6 volume called SYSTEM. This will 
be substituted later for the SYS:SYSTEM directory for GroupWise. 

3. Create several new users using ConsoleOne. You will add these users to the 
GroupWise system during installation. This addition will enable you to send 
email to different users to test the connections. User names may be selected 
at random. 

4. Exit ConsoleOne. 
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Exercise 2 — Installing GroupWise 
1. Browse the GroupWise6 folder under ClassPaq to the install file. Double-

click Setup.exe. 

 
 

2. The Novell GroupWise 6 screen displays. Select Install Products → 
GroupWise Administration → Install GroupWise Administration → Yes. 
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3. The Welcome screen displays. Click Next → Next. You will not select the 
option to Plan your system for this exercise. Verify that the Create a new 
system or update an existing system option is selected. Click Next. 
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4. The Select Tree dialog box displays. Select the CPQ tree. Click Next to 
extend the NDS schema. Then select Next → Next. 

5. The Select Language screen displays. English-USA is selected by default. 
Click Next. 

 
 

6. At the ConsoleOne Path screen, ensure that the correct path for ConsoleOne 
files is displayed.  
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7. The Software Distribution Directory screen displays. At the Select a location 
for the… field enter G:\grpwise\software for the location and click 
Next. 
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8. Ensure that the following options are selected: 

• GroupWise ConsoleOne Snapins 

• NLM Agents 

• Windows 95/98/NT/ Client 

9. No other options should be selected at this time. Click Next. 

10. The Ready To Install screen displays; click Install to begin installation. 
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11. The Novell GroupWise Partner screen displays. Click Next to continue. 

 
 

12. The Determine Next Step screen displays. Select the Creating a new 
GroupWise system? option and click Next  → Run. You will now have the 
opportunity to start the GroupWise Setup Advisor to configure the system. 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

L11 – 10 Rev. 2.11 

 
 

13. At the GroupWise Setup Progress screen, select Next → Next → Next to 
proceed to the System Name screen.  
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14. Use the following configuration parameters. 
 

Item Configuration Parameters 
NDS Tree CPQ 
System Name CPQGW 
Domain Name GWCLSTR 
Domain Directory G:\domdir 
Domain Context NCS (must select with the browse button) 
Domain Language English – US (or appropriate language support) 
Time Zone Applicable Time Zone 
Post Office GroupPO 
Post Office Directory G:\podir 
Post Office Context NCS 
Post Office Language Applicable Language 
Post Office Time Zone Applicable Timezone 
Post Office Access 
Method 

Client/server access only 

Post Office Link TCP/IP link 
POA Network Address 
(The POA delivers 
messages to users’ 
mailboxes.) 

 

TCP/IP Address 172.20.100.30 
(Static IP Address assigned to volume) 

Client/Server Port 1677 
Message Transfer Port 7101 
HTTP Port 7181 
MTA Network Address 
(Routes messages 
between domains, post 
offices, and gateways.) 

 

TCP/IP Address 172.20.100.30 
(Static IP Address assigned to volume) 

Message Transfer Port 7100 
HTTP Port 7180 
Post Office Users  
Add Select users created in earlier exercise, including Admin  

account. 
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15. The GroupWise Setup Progress (Create System) screen displays. Click Next  
→ Next. Files will copy and post office will form. The Please Wait screen  
displays to indicate that the installation is complete. Click Next. 

16. Click Next (Install Agent Software) → Next (Installation Platform = 
NetWare).  
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17. At the Installation Path screen, select the path g:\system as the path for 
GroupWise agent software and ensure that the Configure GroupWise agents 
for clustering option is selected. Click Next.  
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18. The Web Console Information screen displays. Deselect Enable web console. 
Click Next → Next (Language) → Install (Summary screen). 
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19. The Installation Complete screen displays. Deselect the Update AUTOEXEC 
file and GroupWise agents now options. Click Finish → Next. 

 
 Note 

The AUTOEXEC.NCF file should not be modified to auto-start the 
GRPWISE.NCF file. This is because it is desired to launch GroupWise from 
within a cluster resource load script. 

 
20. Select the appropriate language, then select OK. 
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21. GroupWise 6 requires the Windows Messaging System. If is not already 
installed on your system, follow the prompts to install it. The system will 
need to restart. If it is installed on your system, proceed to step 23. 

22. When Windows comes back up, log in as admin. The GroupWise Setup 
program will continue. Select the appropriate language and click OK. At the 
Welcome screen, click Next. 
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23. The ConsoleOne screen may display briefly, then the Setup Options screen 
displays. Click Next (Standard Install)→ Next → Next (Destination 
Directory). 

 

 
 

24. Ensure that only the GroupWise option is selected. Deselect the GroupWise 
Tip of the Day, and Internet Browser Mail Integration options. Click Next → 
Next. 

25. The GroupWise Notify option does not need to be selected. Select Next → 
Next → Next → Next to start the file copy process. 
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26. A file copy and installation progress screen displays. After the process is 
complete, the View Readme File and Launch GroupWise Now screen 
displays. Deselect both options. Click Finish.  

27. If necessary, close ConsoleOne and exit the GroupWise installer. 
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Exercise 3 — Configuring the GroupWise Home Directory 
As mentioned in the beginning of this lab, you must verify the configuration path 
to the POA and MTA home directories. The home directories reside on the shared 
storage. Configuring the paths allows GroupWise to find the Post Office directory 
and the Domain directory when a server fails over. 

During the GroupWise Agents portion of the installation, you selected the 
G:\System directory to contain the agent software.  

During the process that installed the agents, the POA and MTA startup files were 
created. These startup files include a path statement pointing to the Post Office 
directory and the Domain directory on the shared storage volume. The startup files 
need to be configured for an NCS environment by modifying the path statement. 

To correctly identify the path statement, the MTA and POA startup files on the 
shared storage must be edited. Editing the POA and MTA startup files can be 
performed from the server console using the built-in text editor or from a 
workstation using any generic text editor. 

1. Use any text editor to edit the G:\System\GROUPPO.POA file. This will 
open the post office file. 

2. Scroll down to the Post Office Directory entry and verify that the following 
path is present: 
/home-GPW:\podir\ 

3. After the POA startup file has been edited, save your changes. After saving, 
navigate to the G:\System directory, and browse to the MTA startup file. If 
your Primary Domain name is GWCLSTR, the startup file will be 
GWCLSTR.MTA. After you have selected the MTA startup file, open it for 
editing. 

4. This file is similar to the POA, except that it points to the Domain directory 
instead of the Post Office directory. Verify that the following path is present: 
/home-GPW:\domdir\ 

5. Exit the Edit program.  
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6. At the server console for Node1, execute GPW:SYSTEM\grpwise.ncf. 

7. At the desktop, launch GroupWise. 

 

 
 

8. The GroupWise Startup screen displays and proceeds directly to the 
GroupWise-Mailbox screen. Because you are currently logged in as Admin, 
this is the mailbox for the admin user.  

 
 Note 

Another startup screen might prompt you for information. If so, enter the 
USERID, Password, TCPIP address and Port. Type one of the user names you 
created earlier, its password, the IP address of the POA and MTA, and the 
default POA port of 1677. Click OK. If this screen does not display, proceed. 
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9. Send a test message to the Admin account. If it is received, the system is 
working properly. Exit the GroupWise client and close any readme files or 
tips screens before proceeding. 

You have just completed the installation of your GroupWise system. On the 
console for Node1, the MTA and POA screens should be active and displaying the 
status of the Domain and Post Office that were just created.  
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Exercise 4 — Modifying the GroupWise NSS Cluster-
Enabled Volume Resource to load GroupWise Services 

1. Before configuring the VIRTUAL_GRPW6 NSS cluster-enabled volume as a 
cluster resource in ConsoleOne, perform the following steps: 

a. At the server console for Node1, shut down the MTA and POA on 
Node1 by moving to the POA and MTA screens and pressing F7 to Exit 
the system and unload the following NLMs: 

 Gwmta 

 Gwpoa 

 

 
 

b. Use ConsoleOne to put the Virtual_Mail resource in an Offline state to 
disable the cluster-enabled volume. 

 
 Note 

Because the POA and MTA databases have just been shut down, a GroupWise 
Administrator message may display indicating that the database cannot be 
found. Ignore this message and select Cancel → Close. 
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2. Use the ConsoleOne Console View to select the Virtual_Mail cluster 
resource object. Right-click on that object and select Properties.  
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3. Edit the load script to look like the following:  

 
 

The Load script activates the NSS volume and mounts it, then adds the secondary 
IP address defined for the GroupWise Mail Server, and launches GroupWise. 
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4. Click the Unload tab. Edit this script to look like the preceding example. 

This script unloads the MTA and POA modules, which shuts down 
GroupWise, dismounts and deactivates the NSS volume, and deletes the 
secondary IP address used for the GroupWise clustered resource. 

5. Click the Policies tab. Ensure that the Start and Failover modes are set to 
Auto, and the FailBack mode is set to Disabled. 

6. Click the Nodes tab. Ensure that all desired servers in your cluster displays in 
the assigned column. The assignment sequence is shown from top to bottom. 
For example, if the list displays Node1 before Node2, Node1 is the first 
assigned server or primary owner of the cluster resource. Exit the Properties 
screen by selecting OK. 

7. ConsoleOne displays in the Console View mode. Click the View item on the 
menu. Select Cluster State view. 
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8. A graphical representation of your cluster displays. The GroupWise resource 
displays as offline or NDS Sync in the lower right pane. Click the 
Virtual_Mail resource name once. 

 
 Note 

If the State indicates NDS Sync for more than a minute, you might need to 
reset one of the server nodes. 
Check the server console to ensure that the Post Office and Domain are open. 
ConsoleOne only indicates that the cluster volume or resource is online, not 
whether the application or server is actually functioning properly. 
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9. The Cluster Resource Manager displays. Select Node1 and click the Online 
button to load the GroupWise Resource, which is monitored on the server 
console. After the Resource is loaded, ConsoleOne shows it as online. 

10. After you have verified that the Post Office and Domain are open and 
running on the node, click the GroupWise resource entry from the Cluster 
State View in ConsoleOne. The Cluster Resource Manager displays, 
indicating which server controls the resource, and the servers that are 
available to which to migrate.  

11. Click the name of Node2 and click Migrate. The clustered resource should 
migrate over to the other clustered node. After the resource reaches a 
Running state on the other node, proceed to the next step. 

12. On the Management Workstation, double-click the GroupWise icon on the 
Desktop. The Novell GroupWise splash screen displays and the GroupWise 
startup screen displays. This will attempt to connect to the Post Office 
automatically. 

 
 Note 

Another startup screen might ask you for the USERID, Password, TCP/IP 
address, and Port you want to log in to. Enter one of the user names you 
created earlier, its password, the IP address of the POA and MTA, and the 
default POA port of 1677. Click OK. If you are not asked for this information, 
you will enter in to the mailbox of the currently logged in user. 

 
13. The GroupWise mailbox for the user should display. From this user’s 

mailbox create a new mail message for one of the other users you created 
earlier. Click Send while watching the GroupWise POA screen on the server 
console. You should see the message being transferred on the server console. 

14. Exit GroupWise. 

15. Using ConsoleOne, migrate the GroupWise cluster resource. 

16. After the resource is launched, ensure that the Post Office and Domain NLMs 
are both running.  

17. Log in as the user you sent mail to in step 13. The IP address and port should 
display correctly. 
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18. On the management workstation, double-click the GroupWise icon. The mail 
you sent should be there.  

19. Reply to the user but attach the Workshop.RTF file to the email. Carbon Copy 
the current user on the reply. 

20. Immediately after sending the message, use ConsoleOne to migrate the 
GroupWise resource. 

21. After the resource has been successfully migrated, verify that the target user 
has received the email with the attachment despite the injection of the fault. 

You have now successfully installed and clustered the GroupWise application. 
You can continue to experiment fault injections while sending email with 
GroupWise. Some sample fault injections include: 

 Pull GBICs 

 Pull Fibre Channel cable 

 Shut down the server node currently running GroupWise 
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Troubleshooting Novell Cluster 
Services on Compaq ProLiant Clusters 

Lab 12 

Objective 
After completing this lab, you should be able to troubleshoot some problems that 
might arise in a clustered environment. 

Requirement 
To complete this lab you will need: 

 A Compaq ProLiant cluster.  

 Compaq Array Configuration Utility (ACU) or appropriate storage 
configuration utility. 

 Access to appropriate troubleshooting tools. 
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Exercise — Troubleshooting ProLiant Clusters 
The instructor will give you an extended break. During this break, the instructor 
will introduce problems into your cluster. Do not re-enter the classroom during the 
break. 

The type and number of problems introduced into the working clusters will vary. 
Each group will have at least two errors to locate. 

After returning to the classroom, you will work with your assigned lab group to 
troubleshoot your cluster. You must restore the cluster to a fully functional state, 
and report the problems to the instructor for verification. You should also be able 
to use ACU to show the array configuration of your cluster to the instructor. 
 
 Note 

During the troubleshooting process, course participants are not allowed to 
reinstall the operating system or NCS unless directed to do so by the instructor.

 
In the following table, record all errors introduced into the working cluster and 
how those errors were resolved. 
 
Error How Resolved 
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Configuring the StorageWorks 
RA4x00 Storage Array by Compaq 

Appendix A 

Objective 
The primary objective of this section is to illustrate the steps necessary to 
configure the RA4000/RA4100 storage subsystem. 

Requirements 
To complete this lab, you will need: 

 RA4000/RA4100 storage subsystem with dual RA4000 controllers. 

 CPQONLIN.NLM array configuration utility. 

 66MHz/64-bit PCI-to-Fibre Channel adapter. 

 Fibre Channel interconnect components 

• Fibre Channel Arbitrated Loop (FCAL) hub 

• FCAL loop-switch 

• SAN Switch 8/16 

This lab is not intended to provide step-by-step instructions on configuring the 
RA4x00 storage subsystem.  
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Exercise — Creating Logical Drives for the RA4x00 
To create new logical arrays: 

1. Shut down and power off all cluster servers. 
 
 Note 

There are two storage Fibre Channel interconnects. Do not alter their power 
configuration at this time. One interconnect should remain powered off so that 
the cluster can begin with a base configuration.  

 
2. Power on the storage subsystem if it is not already powered on. Wait for it to 

fully initialize. 

3. Power on the cluster servers one at a time, starting with the server that 
contains the master replica Novell Directory Services (NDS) tree (node 1). 

4. On a cluster server, enter CPQONLIN to start the Compaq Online 
Configuration Utility. 
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5. In the Available Options box, select Array Configuration Utility and press 
Enter. 

 
 

6. From the list of active array controllers, select an RA4000 controller in the 
storage subsystem you are configuring. The storage subsystem is identified 
by a name assigned during the SmartStart configuration; Orion I in the 
example screen. Then press Enter. 

 
 Note 

In redundant Fibre Channel loop configurations, the Fibre Channel arrays will 
automatically find the new redundant path; therefore, no additional 
configuration steps need to be performed. Ensure that you use the correct array 
controller firmware (2.58) on all array controllers, as specified in the Compaq 
ProLiant Cluster for NetWare 5 Certification Matrix at the website 
http://www.compaq.com/highavailability. 
Use CPQONLIN or Compaq Insight Manager to find the version of the 
firmware on the array controllers RA4x00 only. 
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7. A box showing the drives in the storage subsystem displays. The drives have 
not yet been assigned to a logical array. 

  
8. In the Select Fault Tolerance box, select Custom Configuration and press 

Enter. 

  
7. In the Controller Options box, select Create New Array and press Enter.  
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9. This creates a new logical array. 

  
10. Assign physical drives to the array by selecting Assign Drive to New Array 

and highlighting drives in the Physical Drives list. The drives you assign to 
the new array displays in the New Array box.  

Drives assigned
to new array
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11. When finished assigning drives to the new array, select Accept Changes and 
press Enter. Create the following logical drives at RAID level 5: 

 
Resource Use (Names to 
be applied later. They are 
listed here for 
informational purposes 
only.) 

 
 
 
Approximate Logical 
Drive Size (MB) 

Split Brain Detector (SBD) 20 
Split Brain Detector (SBD) 20 
Cluster-Enabled Volume 
NSSVOL1 

1024 

Cluster-Enabled Volume 
NSSVOL2 

1024 

Netscape Enterprise Server 
Resource (optional) 

1024 

GroupWise Resource 1024 
Oracle 2048 or greater 

 

  
12. Enter the desired RAIDset options. The options are Array Accelerator, Fault 

Tolerance (RAID level), Stripe Size, and Logical Drive Size. Press Esc to 
save your entries. 
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13. Select Yes when asked if you want to create a logical drive. The Array 

Configuration Utility displays the following warning: 

  
14. Select No. 
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15. The configuration utility displays a summary of the new configuration, 
showing the logical drives and the settings you have established. 

  
16. Exit the CPQONLIN utility and restart all cluster servers one at a time. This 

completes the array configuration procedure. 
 
 Note 

Compaq recommends that all disk configurations be performed from the same 
server. 

 
After the configuration is complete, check to ensure that the cluster servers 
recognize the same drives and free space on the storage subsystem and that the 
disk partitions are valid. You can perform this check by using the NWCONFIG 
utility: 

17. Start the NWCONFIG utility. 

18. On the first screen, select Standard Disk Options and press Enter. 
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19. On the next screen, select Modify Disk Partitions and press Enter. Confirm 
the array configuration on the resulting display. 

   
 Note 

You should also check each logical disk device to ensure that they are usable 
by NetWare. Ensure that the device shows up in the Available Devices screen. 
The disk drives used in the logical arrays should be clear of any data. If the 
drives were previously used or were taken from another system, use the 
Initialize Disk option to remove any pre-existing data from the drives. 
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20. You can also view details about attached storage devices by entering a LIST 
DEVICES command at the system console prompt to display a screen similar 
to the following. 
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Configuring the StorageWorks 
MA8000/EMA12000 Storage Array by Compaq 

Appendix B 

Objective 
After completing this lab, you should be able to set HSG80 controller parameters. 

Requirements 
To complete this lab, you will need: 

 RA8000 or MA8000 storage subsystem. 

 Two HSG80 controllers not configured for redundancy. 

 Client computer. 

 Windows 2000 Professional. 

 HyperTerminal. 

 HSG80 maintenance cable. 
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Exercise 1 — Communicating with the RAID Controller 
This section of the lab will show you how to connect the controller to the host 
computer and establish communication between them.  

Checklist 
On completion of each exercise, have your instructor verify that you have 
performed it successfully by examining this checklist. Mark off the following as 
you are able to: 

 Establish a CLI session with an HSG80 array controller. 

 Configure an HSG80 controller for operation within an arbitrated loop or 
switched fabric environment. 

 Configure dual HSG80 array controllers for multibus and transparent failover 
mode. 

 Successfully power down an HSG80-based storage subsystem. 

Verifying Serial Cable Installation 
A DB9 female to an RJ12 serial cable will connect the array controller to the client 
computer system. The RJ12 end of the cable connects to the maintenance terminal 
port of the HSG80 controller. 
 
 Note 

There is only one RJ12 port per controller. 
 
The other end of the cable (DB9) can be connected to any available COM port on 
the client station.  
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Starting Up HyperTerminal 
A Command Line Interpreter (CLI) session can run through any of the following 
terminal emulation software: 

 Terminal 

 KeaTerm 

 HyperTerminal 

 VT 

 UNIX tip program  

You will use HyperTerminal in this lab exercise. 

1. Start HyperTerminal by following the file path Start → Programs → 
Accessories → HyperTerminal → HyperTerminal. 

2. A Connection Description dialogue box displays. Enter a name for the new 
connection in the text box and select an appropriate icon. Enter StorageX 
where X represents the number of your lab station. Select OK. 

3. A Connect To dialogue box displays. Select the appropriate COM port in the 
drop-down list box located at the bottom of the dialogue box. This is the port 
on your client station that the maintenance cable is attached to. Select OK. 

4. You should now see a dialogue box called COMx Properties where “x” 
represents the COM port that you selected in the last step. Set the parameters 
in this dialogue as follows. 

 Bits per second = 9600 

 Data Bits = 8 

 Parity = None 

 Stop Bits = 1 

 Flow Control = Hardware 
 
 Note 

Under the file path File → Properties → Settings → Emulation, set the 
emulation to VT100. If this setting is incorrect, the user could be unable to use 
the Delete key to correct mistakes in the command line. 
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5. After these settings have been verified, select OK. 

6. Press Enter twice. HyperTerminal will respond with a prompt, for example 
HSG80>. This indicates that communication with the controller has been 
established.  

If HyperTerminal does not respond with a prompt and only a blinking cursor 
displays after pressing Enter several times, you must disconnect from 
HyperTerminal. Do this by clicking the Disconnect choice under the Call 
menu.  

a. Check to see if the correct COM port has been selected. To do so, 
follow the path File → Properties → Connect. Verify that the controller 
is active (a green restart button should flash.) Then, verify that the cable 
is properly attached and the communications settings are 9600, 8, None, 
1, and Hardware. Do this by following the path File → Properties → 
Configure.  

b. If these settings are correct and there is still no connection, try setting 
the baud rate to 19200. If communication continues to fail, reset the 
baud rate to 9600.  

c. If two controllers are installed in the storage system, try communicating 
with the other controller.  

If, after trying these solutions, communication is still not established, please 
see the instructor. 
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Establishing Controller and Other Basic Settings 

Help and Basic Settings 
1. To get help from the HSG controller using the ?, use the following 

commands. 

a. Enter ?. This will show all commands currently available. 

b. Add ?. This will get help at a lower level. 

c. Enter the following commands: 
ADD DISK ? 

ADD DISK DISK10000 

ADD DISK DISK10000 5 ? 

SHOW ? 

The following CLI keyboard shortcut keys are available.  
Shortcut Keys Function 
Up Arrow/Down Arrow Step back and forth through the most recent CLI commands 
Left Arrow/Right Arrow Move the cursor left or right in the command line 
Ctrl + E Move the cursor to the end of the line 
Ctrl + H or Backspace Move the cursor to the beginning of the line 
Ctrl + A Toggle between insert and overstrike 
Ctrl + R Recall contents of the current command line 

 
2. Use the SHOW command to display the configuration settings of the controller. 

SHOW THIS FULL 

What is the port topology of the controller you are viewing? Write the 
topology type in the space provided below. 

 
 Note 

The four valid settings for topology are LOOP_SOFT (arbitrate for an AL_PA, 
LOOP_HARD (assign a hard-coded AL_PA), FABRIC (for switched fabric) 
and OFFLINE (do not partake in the arbitrated loop or fabric). The port 
topology can be changed with the following commands: 
SET THIS PORT_1_TOPOLOGY=LOOP_SOFT 
SET THIS PORT_1_TOPOLOGY=LOOP_HARD 
SET THIS PORT_1_TOPOLOGY=FABRIC 
SET THIS PORT_1_TOPOLOGY=OFFLINE 
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3. Set the time on the controller by entering:  
SET THIS TIME = ?  

This will show the time format. Go ahead and set the time for the controller. 

4. Set the Cache Flush Timer on the controller to 10 by entering: 
SET THIS CACHE_FLUSH_TIMER=10 

5. Set the HSZ prompt by entering: 
SET THIS PROMPT=“HSG80->” 

6. Set the Allocation Class to zero by entering: 
SET THIS allocation_class=0 

 
 Note 

Windows NT does not use this setting. It is, however, used by OpenVMS and 
Digital Unix in response to SCSI inquiry commands. It is a means for those 
operating systems to identify controller pairs uniquely. 

 
7. Set the EMU parameters by entering: 

SHOW EMU 

SET EMU FANSPEED = HIGH 

SET EMU FANSPEED = AUTO 
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Establishing Transparent and Multibus Failover Mode 
By default, the controllers ship from the factory in transparent failover mode. To 
set the controllers to transparent failover mode, you simply enter whichever of the 
following is the source of the correct information. 

SET FAILOVER COPY = THIS  

To get into multibus failover mode you must first get the controllers out of 
transparent failover mode. 

SET NOFAILOVER 
 
 Note 

The NOFAILOVER command can be entered from either controller. 
 
After the controllers have been taken out of their default, dual-redundant 
(transparent) configuration, they can be reconfigured for multibus operation. To 
configure the controllers for multibus operation; 
SET MULTIBUS_FAILOVER COPY = THIS 

This will configure the controllers for multibus failover mode, based on the 
configuration of the controller you are currently attached to. 
SET NOMULTIBUS_FAILOVER 

This will return to transparent failover mode from multibus failover mode; 
SET FAILOVER COPY=THIS 

This will return the controllers to transparent failover mode, based on the 
configuration stored controller you are currently attached to. 
 
 Note 

When changing the redundancy options for the controllers, the other controller 
will automatically shut down when the redundancy settings are changed. 
Ensure that the other controller has restarted before attempting to resume the 
reconfiguration procedure. 
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The following graphic is a depiction of each failover mode. In the transparent 
mode, the only units that can be seen out of port 1 are D0 through D99. The only 
units that can be seen out of port 2 are units D100 through D199. In the multibus 
mode, all units (D0 through D199) can be seen out of both host ports. 
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Powering Off the System 
If the controllers have been shut down cleanly, the OCP Reset button is solid green 
and the three port indicators nearest the OCP Reset button are solid green. If this 
unit needs to be shipped, the ECBs should be shut down. Depressing the button 
labeled Shut Off for several seconds accomplishes this. 

Before the HSG80s, shutdown was achieved by entering the command SHUTDOWN 
OTHER followed by SHUTDOWN THIS. Although the HSG80s still have and use the 
SHUTDOWN command, POWEROFF enables you to accomplish the same task with 
one command instead of two. 

The BATTERY_ON switch instructs the subsystem to leave the cache module 
power on. The default is BATTERY_OFF. In either case, the ECB will not be shut 
off. You need to push the ECB Shut Off switch to disable the battery shipping the 
subsystem.  

 Note 
There is no ECB Shut Off switch on the M2200 controller shelf. 

 
After the POWEROFF command has been issued, all units go into a write-through 
caching state until the time specified in the Seconds switch. After this time has 
elapsed, there is an orderly rundown of units followed by a shutdown of both 
controllers. Then the DC power is powered off. 

1. Enter POWEROFF SECONDS = 5 BATTERY_ON. 

2. Wait for the subsystem to shut down. After the system shuts down, restart 
both controllers by depressing the EMU reset buttons. 

You have now completed this lab exercise. Please inform your instructor that you 
have finished. 
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Exercise 2 — Configuring the Storage System with CLI  

Objective 
After completing this exercise, you will be able to create and manage different 
types of storage containers. 

Requirements 
To complete this exercise, you will need: 

 MA/RA8000 storage subsystem 

 2 HSG80 controllers configured as follows: 

• Dual redundancy (transparent failover mode) 

• Mirrored cache mode 

• Port one on the top controller and port two on the bottom controller 
attached to a hub or switch 

 Six hot-plug universal hard drives or disk storage building blocks (SBBs) 
installed in drive cabinet 

Checklist 
On completion of each lab exercise, have your instructor verify that you have 
performed it successfully by examining this checklist. Mark off the following as 
you are able to: 

 Add disk devices 

 Create different container types—specifically RAIDsets, MIRRORsets, and 
striped mirrorsets. 
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Checking for Previous Configurations 
Before beginning this lab, verify that no controller storage set configuration 
information exists. If it does, this information should be deleted in the following 
order: units, containers, and devices. 

Deleting All Units 
7. Enter SHOW UNIT To obtain existing unit numbers. 

8. Enter DELETE D100 To delete existing units listed under the LUN column. 
D100 is presented as an example. In class, you would need to delete whatever 
units were displayed after typing the SHOW UNIT command. 

Deleting All Storage Containers 
9. Enter SHOW STORAGE to obtain existing storage containers. 

10. Enter DELETE M0 to delete existing storage containers listed under the 
Name column. In this example, M0 is the name of the storage container. In 
this lab, you will need to delete whatever storage containers were displayed 
after entering the SHOW STORAGE command. 

Deleting All Devices  
To delete devices: 

11. Enter Show Disks to view existing device containers. No Devices should be 
displayed. 

12. Enter DELETE DISK10000 to delete existing device containers listed under 
the Name column. You will need to delete each disk device individually 

Verifying LUN, Container, and Device Removal 
For verifications: 

13. Enter SHOW UNIT. No LUNs should be displayed. 

14. Enter SHOW DEVICE. No disk devices should be displayed. 

15. Enter SHOW STORAGE. No storage containers should be displayed. You 
might see two containers named Failedset and Spareset. These are 
placeholders. They should not contain any disk devices. 

 
 Note 

Again, the preceding steps should not be necessary. They are listed in the 
unlikely event that the storage subsystem was not properly ‘refreshed’ prior to 
class. However, knowledge of the various uses of the SHOW command is 
useful. 
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Using the CONFIG Utility 
1. Enter RUN CONFIG. 
 
 Note 

This utility will automatically configure all devices currently seen by the 
controller. It will scan all SCSI buses looking for disk devices, and then create 
internal reference names such as DISK10000. This utility will not remove any 
devices that were previously configured but no longer exist. 

 
2. Enter SHOW DISK. At minimum, DISK10000, DISK20000, 

DISK30000, and DISK40000 should display. 
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Exercise 3 — Using StorageWorks Command Console to 
Complete Configuration of Storage System 

Objectives 
After completing this exercise, you will be able to: 

 Understand how to install StorageWorks Command Console (SWCC) agent 
and client software. 

 Explain how to establish the three types of connections to the subsystem. 

 Describe how to configure and maintain a remote subsystem through the 
SWCC graphical user interface (GUI). 

 Create a virtual disk using the SWCC Storage Window. 

Requirements 
To complete this exercise, you will need: 

 1 MA/RA8000 storage subsystem 

 2 HSG80 controllers configured with dual redundancy (transparent failover 
mode) 

 At least one disk device installed in drive cabinet 

 At least one LUN (D1) created beforehand 

 1 host running NetWare 5.1 SP2 with one 64-bit Compaq Fibre Channel Host 
adapter 

 One client station running Windows 2000 Professional with the following 
installed: 

• Fibre channel cables 

• At least one fibre channel interconnect device 

Your instructor can provide you with the location of SWCC software. Write this 
location in the space provided below: 

............................................................................................................................  

 

Client and server can communicate through TCP/IP on the classroom LAN. 
Record the IP addresses of your client and server in the space provided below: 

............................................................................................................................  
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Checklist 
Upon completion of each exercise, have your instructor verify that you have 
performed it successfully. Check the following list as you are able to: 

 Install the client and agent components of SWCC. 

 View an HSG80-based storage system through SWCC through serial, 
SCSI, and network configurations. 

 Create a virtual disk using the SWCC Storage Window application. 

Configuring Hardware and Physical Connections 
Your lab station should be configured as shown in the following diagram: 

 
 

Verify the following: 

 The Fiber Channel cables are properly seated. 

 The controller’s ACS version is appropriate for the topology you are using. 
For example, if you are using ACS8.5P, you will not be able to conduct this 
lab within an arbitrated loop topology. 

 Note 
This lab can be run in either FC-SW or FC-AL environments. If you have any 
questions regarding the use of a FC switch or hub, please ask your instructor 
for assistance. 

 

TCP/IP LAN 
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 A maintenance cable connects your client station (or server) to the top 
HSG80 array controller. 

 HBA device and drivers are loaded and are functioning properly. 

Installing the MA/RA8000 NetWare SWCC Agent Configurator 
1. Attach with administrative rights to the server to which you wish to install the 

agent. 

2. From the RA8000_NW\SWCC\NETWARE_AGENT, launch SETUP.EXE → 
Next. 

3. Enter the name of the desired server node. 

Configuring the Agent Services  
4. On the NetWare console, enter load HSG80CFG. 

5. Select Edit Client List → INS and enter the name of the client from which 
commands will be received. 

6. Select Modify for client priviledges, and Both for monitor mode. 

7. Enter a password for the client. 

8. Save and exit the HSG80CFG information. 

9. To load the NetWare SWCC Agents, enter the following at the server 
console: 
Load RAIDCDM 

Load STEAM 

10. The management console (Command Console Client) can now connect to the 
array. 

 
 Note 

Ensure that the SYS:ETC/HOSTS file has been edited with the name of the 
management PC, or that DNS is enabled. 
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Installing the Command Console Client 
11. On the platform kit CD, move to the folder: 

drive_letter:\SWCC\Client\hsg80_intel 

12. Choose Intel client then double-click on Setup. 

13. Follow instructions in the Setup program to complete the installation. 

14. The management console is now prepared to connect to the SWCC agent 
running on the server node. 

Using SWCC CLI Window Through A Serial Connection 

Opening the SWCC CLI Window 
15. Follow the path: Start → Programs → Command Console → CLI Window. 

16. Select Serial communication type, the appropriate COM port setting, and a 
baud rate of 9600. Click Connect and wait for the CLI window to display.  

 

 
17. Enter SHO THI FUL to show the controller’s configuration. 

18. Enter SHO UNI FUL to verify the existence of the communications LUN. 

19. Exit from the CLI Window. 
 
 Note 

There are a few limitations of the SWCC CLI window. First, RUN commands 
can not be initiated through this interface—they must be performed through a 
maintenance terminal port. However, the CLI window does have type-ahead 
capabilities. 

 

!  
Warning 
If a HyperTerminal session is running and you attempt to run SWCC 
Client in serial mode, it will not work. Although the serial session 
begins, nothing happens when you enter CLI commands. 

•  
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Using the SWCC CLI Window Through a Network (TCP/IP) 
Connection 

Opening the SWCC Client Window 
1. Select Start → Programs → Command Consolev2.0 → CLI Window. 
 
 Note 

The only other Connection Selection for the CLI Window is SCSI. To use the 
SCSI connection, you need to be running the SWCC Client software directly 
from the server attached to your storage subsystem. Then pick any drive letter 
associated with a LUN configured behind the controllers to start the CLI 
session. 

 
2. Select Network (TCP/IP) Communication type and click OK. 

  
3. Enter the computer name or IP address of the server that is running the HS 

Agent in your lab station. Click Detect Subsystems. The subsystem 
information should display in the space provided. Click Connect. 

  
 Note 

Do not manually enter a subsystem name. If this field remains blank after you 
have selected Detect Subsystems, you will have to troubleshoot your 
installation. See the “Troubleshooting SWCC” section located in the appendix 
of this lab guide. 

 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

B – 18 Rev. 2.11 

4. You will now see the SWCC CLI window. Enter some simple CLI 
commands to demonstrate the funcationality of this application. 

5. Enter SHO THI FUL to display the controller’s configuration. The CLI 
window will respond with the following security check: 

  
 Note 

Notice that this dialog box did not display when we were using a maintenance 
cable plugged into the array controller. 

 
6. Enter the password you assigned when installing the Agent and click OK to 

see the results of your query. 

7. When the connection has been verified, exit the CLI session. 
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Using the SWCC HSG80 Storage Window Through TCP/IP 
 

▲ Note 
The HSG80 Storage window only allows a user to access one storage 
subsystem at a time. Like the CLI window, it can also be opened using a serial 
or SCSI cable. 

Opening the HSG80 Storage Window 
1. On your client station, follow the path: Start → Programs → Command 

Console → StorageWorks CC HSG80ACS8.5 

2. Select Network (TCP/IP) Communication type and click OK. 
 
 Note 

You could use the serial connection here if you had a serial cable connected 
between the computer and the storage subsystem. You could also use the SCSI 
connection if you were running the SWCC Client directly from the server that 
was attached to your storage subsystem. 

 
3. Enter the computer name or IP address of the server that is currently running 

the HS Agent. 
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4. Click Detect Subsystems. The Client will search the server (using TCP/IP) for 
a running agent and list any subsystems it finds running behind that Agent. It 
will display similar to the following graphic: 

 
 

For the purpose of this lab, the Subsystem Physical View will be left at “24-
Device” and the Subsystem Grid View will be “6 Channel Small”. Click 
Connect and wait for the subsystem to be scanned. 

5. The client, working through the agent, will scan the subsystem and acquire 
data from the controller. The subsystem is presented in a Grid view based 
upon your selection in the last dialog box. Use the View pull-down menu to 
verify that the current view is the Grid view.  
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6. The Communications LUN is listed under the virtual disks area (SWCC 
refers to LUNs as virtual disks) at the top of the display. The grid Devices 
display identifies the disks that are members of virtual disks by highlighting 
them in bright green. 

Using the Storage Window 
7. Double-click one of the green highlighted disk devices in the grid. 

8. Click each of the tabs in the pop-up window (General, Membership, and 
Support Information) to see the details gathered by the Command Console 
Client. Identify the transfer rate and the firmware revision for the drive and 
write this information in the space provided below.  

 

............................................................................................................................  

9. Click OK to close the Properties window. 

10. Double-click the Controllers 1 icon at the bottom of the grid and click 
through the tabs (General, Host Port, Cache, and Communications LUN) to 
see the current settings for the first controller. 

 
 

11. Locate the Port ID for port one on the top controller. Record the value in the 
space provided below. 

............................................................................................................................  

12. Click OK to close the Controller Properties window. 
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13. Click any LUN in the virtual disk window and notice how the devices 
associated with that LUN are outlined within the grid. 

14. Change the views of the Virtual Disks by using the last four buttons on the 
Storage Window toolbar. 

15. Use the Cabinet icon in the toolbar to change from Grid view to Cabinet 
view. 

16. Close and exit the HSZ Storage Window. 

HSG80 Storage Window Menus 
This section briefly outlines the menu options available in the HSG80 Storage 
window. Experiment with any that are of particular interest. Move to the next 
section if you are familiar with all the menu items. 
 
 Note 

You can right-click any device in the Virtual Disks window or Devices 
window to get additional menu choices for that device. For example, right-
clicking on a disk device allows you to mark that device as a spare, remove it 
from being a spare, locate it, or get the properties of it. 

 
17. The first menu item is File as shown here. Selecting New will close the 

current HSG80 Storage window session and prompt you to start a new one. 
Also, there is a Close menu item that will close the current HSG80 Storage 
window applet. 
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18. The second menu item is View. 

  
19. The Virtual Disk submenu looks as follows: 

 
 

Option Function 
Refresh Rescans your subsystem for the latest information 
Toolbar Toggles whether your Toolbar is showing  
Legend Shows all pertinent legend information (for example, what each icon means) 
Virtual Disk Shows the submenu as displayed in the preceding graphic; allows you to choose 

between the four different Virtual Disk views available 
Device Shows the submenu shown in the preceding graphic, which allows you to 

change the Device view from Grid to Cabinet or from Cabinet to Grid, and also 
to change the entire look of the view (for example, it allows you to change 
whether you are looking at a 7-, 24-, 48-, or 72-device storage subsystem) 
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27. The third menu item is Storage. 

 
   

28.   The submenus for Storage are: 
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Option Function 
Add virtual disk Starts the 5-step Add Virtual Disk Wizard for adding LUNs (RAIDsets, mirrorsets, 

JBODs, and so forth). 
Update controller 
software 

Loads a new ACS version over your existing PCMCIA card, or loads a patch for 
your current ACS version. When entered, you will be prompted for the location of 
an .img or patch text file. 

Open Opens an existing controller configuration file for viewing. 
Save Saves the current controller configuration to a file of your choice. 
Load Loads the controllers from a saved configuration file. NOTE: When loading from 

the configuration file, you will be prompted to answer whether this is a new 
installation. If it is new, initialization of all storage containers will take place. Be 
careful because initialization can cause customer data loss. 

Restart Restarts the controller selected in the Device window. 
Restart both Restarts both controllers. 
Delete Deletes any selected virtual disk. A virtual disk will need to be selected before this 

will work. Enter Yes/No to continue after you select this menu item. 
Remove member Removes any selected member from a virtual disk (this is how to reduce a RAID 

or mirror set). Again, a device member will have to be selected before this menu 
item will work. 

Locate Makes the selected virtual disks members flash their fault indicators. You must 
click OK to stop the locate command. 

Add Scans the subsystem for any newly installed disk devices. 
Delete Deletes any selected disk device. 
Make spare Causes the selected disk device to go into the spare set. 
Remove spare Causes the selected disk device to be removed from the spare set. 
Locate Makes the selected disk device flash its fault indicator. 

 
29. The fourth menu item is Options as shown here. Under Security, the option to 

View Only or Make Changes is available. View Only will lock the current 
Storage window session and disables making changes unless you have the 
proper password. Make Changes prompts you for the current password, 
thereby unlocking the current Storage window session. 

 
 

30. The fifth menu item is Help. It gives the standard help item information. 
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Creating a New Virtual Disk with SWCC 
Storage containers (sometimes referred to as virtual disks) can be created through 
either the CLI, or through SWCC. In this section of you will create a new virtual 
disk using the SWCC Storage window. 

1. Select Storage → Add Virtual Disk. Step 1 of the Add Virtual Disk Wizard 
displays. The Add Virtual Disk Wizard consists of five steps. 

 
 

2. In the first step, you are prompted to select a RAID level. For this exercise, 
select Mirrored Device Group (RAID 1). Click Next. 

3. A screen displays prompting you to select the disk devices that you wish to 
include in the new virtual disk. Select any two disk devices, and they display. 
Click Next. 
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4. A screen displays, prompting you to select the maximum capacity of the 
virtual disk you are installing. We will use the default value for this lab 
exercise. Click Next. 

 
 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

B – 28 Rev. 2.11 

5. Step 4 of the Add Virtual Disk Wizard displays. This step provides the 
opportunity to set a wide range of parameters.  

 
 

a. For this exercise, we will assign the name “D4” to the new virtual disk 
by entering D4 in the appropriate text box. 

b. In the space provided, write down three of the drive parameters that 
displays in this window. 

...................................................................................................................  

c. Write down the CLI commands required to implement the parameters 
you listed above. 

...................................................................................................................  

...................................................................................................................  

d. Click Next to continue. 
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6. The fifth step in the Add Virtual Disk Wizard allows you to review the 
configuration settings for the virtual disk you are about to create. If these 
settings are correct, click Finish. If they are not correct, click Back and make 
the necessary changes. 

 
 

7. The wizard will close and the system will scan for the virtual disk you have 
just added. The new drives should display in the Storage window. The green 
highlight indicates that they are now part of a virtual disk. 
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Using the SWCC Navigation Window 

Opening the SWCC Command Console Navigation Window 
1. Follow the path Start → Programs → Command Console → StorageWorks 

Command Console. This opens the Command Console Navigation Window, 
which is designed to allow you to manage many storage subsystems over a 
network. 

2. Follow the path File → Add System. An Add System window displays. 

3. Enter the name or IP address of the server and click Apply. Because there is 
only one host and subsystem in your lab station, click Close when the 
window displays again. 

  
 Note 

If there are multiple storage subsystems to monitor, continue to Add Systems 
until they have all been registered. This is one of the major purposes of using 
StorageWorks Command Console (the other being pager notification of 
subsystem errors). 
In the preceding graphic, there are four subsystem status icons at the bottom. 
From left to right, these icons indicate unknown, good, warning, and failed 
subsystem status states. Using these indicators, you can learn the remote 
subsystem status state. The numbers next to each status icon dictate how many 
subsystems being monitored are currently in that state. 

 
4. In the main window, click the host name of the system to reveal its subsystem 

name. Double-click the Storage Subsystem icon to expand the CLI window 
and Storage window options. 

5. Double-click the Storage Window icon to open the HSG80ACS8.5 Storage 
window. 
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Configuring the ProLiant CL380 
Packaged Cluster Solution 

Appendix C 

Objectives 
After completing this lab, you should be able to: 

 Use the CR3500 Configuration Utility to upgrade controller firmware and 
configure RAID sets. 

 Use Compaq SmartStart to install and configure Novell NetWare with 
supporting Compaq drivers and utilities. 

 Identify modules installed by the SmartStart process loaded during the 
NetWare startup. 

 Replace a failed controller. 

 Upgrade from a single to a dual controller configuration. 
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Exercise 1 — Upgrading CR3500 Firmware with the CR3500 
Configuration Utility 

1. Connect the controller to a system running Microsoft Windows 95/98 or 
Windows NT/2000 using the serial connector on the back of the shared 
storage subsystem. 

1

2

 
2)–Controller - 1 Connection (Top Controller) 

1)–Controller - 2 Connection (Bottom Controller) 

Note: If serial link is being used, both controllers should be connected to machine running the utility  
2. Use a terminal program, such as HyperTerminal to connect. 

3. Use the following settings to connect: 

a. Bit per second = 9600 

b. Data bit = 8 

a. Parity = None 

b. Stop bits = 1 

c. Flow control = XON / XOFF 

4. Power on the shared storage area and press Ctrl-C to abort the controller start 
process. 

5. Select Option 2 to change the baud rate. 

6. Select Option 3 to set baud rait to 38400. 

7. Change the baud rate on the terminal to match the controller’s 38400 settings. 

8. Disconnect and then reconnect the terminal service. 

9. Press Enter to re-establish communication with the controller. 

10. Select Option 1 and press Enter. 

11. Transfer the firmware file as a text file from the terminal service. The entire 
update should take approximately 15 minutes at 38400. 
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12. Select Option 2 after the firmware update, and change the baud rate to 9600 
by selecting 1. 

13. Change the baud rate to 9600 on the terminal service. 

14. Disconnect and then reconnect the terminal service. 

15. Press Enter to re-establish communication with the controller. 

16. Select Option 9 to restart the controller. 
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Exercise 2 — Using the CR3500 Configuration Utility to 
Configure RAIDsets 

1. Connect the Windows 95/98/NT system to the port labeled Controller 1 on 
the back of the shared storage area using a serial cable. Connect another 
serial cable from the Win95/NT system to the port labeled Controller 2 if you 
are using redundant controllers.  

2. Insert the SmartStart CD into the system running Windows 95/NT. 

3. Go to the CR3500 directory on the SmartStart CD from Windows Explorer, 
and run SETUP.EXE. This will install the CR3500 Configuration Utility. 

4. Select Start → Compaq System Tools → CR3500 Utility to run the utility 
when the installation is finished. 

5. Select Serial from the Connection window, and then click OK. 
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6. Choose the COM port (usually COM1) used to make the connection to the 
shared storage array. Click Connect. If you are using a dual controller setup, 
a second serial connection window will display and you must select the COM 
port (usually COM2) for the second controller. After clicking Connect, the 
main window displays. 

 
 

7. Select Add Logical Drive from the Storage pull-down menu. A six-step 
Wizard will assist you in adding a logical drive. 

8. Select the RAID level for the new logical drive. Click Next to continue. 

 



Implementing Compaq ProLiant Cluster Solutions for NetWare 6 

C – 6 Rev. 2.11 

9. Select the physical drives for the new logical drive. The number of physical 
drives you choose will determine the amount of storage that will be available 
for the new logical drive. To select a physical drive, click an available 
physical drive and it will be added to the selected physical drive list. The 
Next button is disabled until the minimum number of disks is chosen.  

 
 

10. Add the capacity for the logical drive. Click Add to create a single logical 
drive using the total capacity available. The capacity remaining changes to 0. 
The new logical drive displays in the bottom window, along with its capacity 
size. Click Next.  
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11. To create more than one logical drive, enter a number less than the amount 
displaying in the Logical Drive Capacity window and click Add. The capacity 
remaining changes to reflect the new amount of capacity in use. Repeat this 
step if you want to create another logical drive, or click Next to continue.  

  
12. Define the strip size and the host port for the new logical drives. Click Next 

to continue. For more information on stripe size and host ports, refer to the 
Online Help. 
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13. Select a Logical Unit Number (LUN) for the logical drive. The Add Logical 
Drive: Step 5 of 6 screen also gives you the option of enabling the Writeback 
Cache to improve host performance. For more information on LUNs and 
Writeback Cache, refer to the Online Help. 
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14. View a summary of the new logical drives. In this summary you will find the 
RAID level, capacity, cache options, and member physical drives that you 
selected for each new logical drive. If you are not satisfied with these 
characteristics, you can go back and make changes by clicking Back. If you 
are satisfied with the summary, click Finish. Click OK when informed that 
the logical drives are being initialized. 

 
 

15. Save the existing configuration. From the Storage pull-down menu select 
Controller → Configuration → Save. The physical drives being configured 
will flash a red “X” while they are being configured. 
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Exercise 3 — Configuring Nodes 
 
 Note 

Except where noted, follow the instructions for the installation of both node 1 
and node 2. 

 

Using SmartStart to Install NetWare 
To prepare the server for an installation of NetWare: 

1. Insert the Compaq SmartStart CD into the CD-ROM drive and power on your 
system. Power on the server node being configured (first node 1, and then 
node 2). The language selection screen displays. The SmartStart program 
supports five languages.  

2. Select the appropriate language. The country selection screen displays. 

3. Select the appropriate country and keyboard style. Enter the date and time, 
then click Next. The System Settings Summary screen displays. 

 
 Note 

If your region uses Daylight Savings Time, check the box for that function. 
  
4. Verify that your information is correct. Select Back to make corrections or 

Continue to proceed. The Compaq SmartStart screen displays. 

5. Check the I Agree box on the SmartStart agreement screen, then click OK. 
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6. Select one of the following paths: 

• Assisted Integration — Walks you through the automated SmartStart 
process 

• Manual Configuration — Allows manual configuration of the system 

• Replication — Creates a server with the same configuration as the one 
previously created with SmartStart, using a Replication diskette made 
during the previous install 
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7. Select Assisted Integration → Begin. 

 
 

 Note 
Beginning immediately after this screen, SmartStart allows the option of 
reviewing the summary of your installation decisions up to your current 
position in the SmartStart installation process. SmartStart also displays a 
navigation bar so that you can determine where you are in the SmartStart 
process. 

 
8. Insert the Server Profile diskette in drive A: of the appropriate node and click 

Next. 

9. Select Next. The Operating System Selection screen displays. 
 

! Important 
Do not remove the Compaq SmartStart CD from the CD-ROM drive or the 
Server Profile diskette from the diskette drive. 

 
10. Select the “+” box next to the Novell folder to open it. The Novell software 

selection screen displays. You are given the option of installing several 
different operating systems, including NetWare for Small Business, NetWare, 
Novell Small Business Suite 5, NetWare 4.2, or NetWare 4.2 SMP. 
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11. Select NetWare → Next → Continue. The system configuration begins. 

12. Follow the System Configuration prompts. SmartStart automatically 
configures the hardware based on the installed EISA or PCI boards and 
storage options. 

13. Complete the following steps for node 1 only: 

a. Select Review or Modify Hardware settings → View or Edit Details. 

b. Scroll down to Dual Channel Wide Ultra2 SCSI Controller (port1). 

c. Highlight the SCSI ID option, press Enter, and change the ID to 6, and 
then press Enter. 

d. Press F10 to signify that the changes are complete. 

e. Scroll down and select Step 5: Save and Exit, and then press Enter. 

f. Press Enter to save the configuration and restart the computer. 

g. Scroll down and select Step 5: Save and Exit, and then press Enter. 

h. Press Enter to save the configuration and restart the computer. 

14. Press Enter to save the configuration and continue with SmartStart. 

15. Press Enter to restart the server and continue with the pre-installation 
interviews.  

The system restarts and SmartStart creates a system partition that allows you 
to run Compaq configuration, diagnostic, and maintenance utilities directly 
from the hard drive. The system will restart again to save the changes to the 
partition table. 
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Pre-Installation Interviews 
At this point, SmartStart displays a summary of software to be installed. 

1. Record the products and their sources in the following table from the 
“Summary of Software Products” list. 

 
Product Name Media Type (Source) 
  
  
  

 
2. Select Next to continue. You will now be guided through the pre-installation 

interviews. 

3. Select Continue on the Guided Pre-Installation Interview screen. 

4. Select Next → Next → Next to configure the Automatic Server Recovery 
options. Do not change any options on these screens. 

 
 Note 

If your server has a Remote Insight Board, you will need to select Next from 
several screens. Answer Yes to the question Do you want to disable alerts? 

 
5. Configure the modem communication options if your server supports the 

Integrated Remote Console (IRC) feature (optional). Select Next to accept the 
default of not configuring IRC. This feature is disabled if the Remote Insight 
Board is installed. 

6. Select Continue to end the Automatic Server Recovery (or Automatic Server 
Recovery and Integrated Remote Console) interview. The NetWare 
Configuration screen displays. 

 
 Note 

If your server has an integrated network interface controller (NIC), you will 
have an opportunity to select the media connector. Accept the default 
10/100Base-T option and select Next. 
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Configuring and Installing NetWare 
At this point in the SmartStart process, you are asked to provide information used 
for the installation of the NetWare operating system. 

SmartStart options allow for Typical or Custom installation. 

1. Select Next in the NetWare Configuration screen. 

2. Select I would like to perform a Custom SmartStart Installation → Next. The 
options available are: 

• I would like SmartStart to configure my DOS Partition. 

• I would like SmartStart to provide updated NSSD to the Novell 
installation process. 

• I would like SmartStart to provide information to the NetWare 
installation process. 

• I would like SmartStart to automatically launch the NetWare installation 
process. 

• I would like to create Support Software Diskettes. 

3. Click Next to accept the defaults. 

4. Insert the Novell license diskette into the appropriate drive A: when 
requested and click OK → OK. 

5. Insert the Compaq SmartStart Server Profile disk when requested and click 
OK. 

6. Specify a 175MB DOS partition and click Next. Then select Continue in the 
NetWare Configuration screen. 

7. Select Summary from the Interviews Complete screen and verify that 
everything is the way you want it before continuing with the NetWare 
installation. Click at the bottom of the screen to return to SmartStart and then 
click Continue. 

8. Click Continue in the Diskette Builder screen. SmartStart will display a 
Notice screen informing you that the system will restart to create and format 
the first disk partition. 
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9. Select Continue. The system will restart, create, and format the DOS 
partition. Files are copied from the SmartStart CD. 

 

! Important 
Do not remove the Server Profile diskette at this time. 

 
10. Select Continue. The system will restart, create, and format the DOS 

partition. Files are copied from the SmartStart CD. 

11. Insert the NetWare Operating System CD and click OK to continue the 
installation. The system restarts and the operating system installation 
proceeds. 

Configuring Storage 
1. The C-Worthy Interface will detect device drivers including the new Platform 

Specific Module (PSM) cpqmpk, and various NetWare Peripheral 
Architecture (NWPA) drivers. Press Enter to select Continue through all 
driver selection process screens. 

2. At the NetWare partition screen, select Modify and press Enter to create a 
NetWare partition and volume SYS. Modify the partition size parameters to 
create a 1GB NetWare partition and a 0-byte Hot Fix space size. Leave the 
remaining disk space unpartitioned for future expansion and NetWare 
Storage Services (NSS) volumes. Press F10 to save your modified partition 
sizes. Select Continue and press Enter. 

The SmartStart NetWare installation process will copy files from the CD to 
the SYS volume. On completion of the file copy, the NetWare install wizard 
will launch the Java graphical user interface (GUI). 

 

! Important 
If the error cannot copy file NWPA.NLM occurs, select Continue copying with 
next file. The file does get copied. 
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Setting Server Properties 
1. Enter the server name NODE01 for node 1 and NODE02 for node 2. Click 

Next. 

  
2. Accept the defaults (NetWare displays the current file system configuration, 

which enables the creation of additional volumes) by selecting Next. The 
Protocols screen displays. 
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3. For node 1: 

a. Highlight the Compaq NetFlex Controller and configure the IP protocol 
with the following information. Click IPX to select it, and then click 
Next. 

1) Address — 172.20.10.1 

2) Mask — 255.255.255.0 

3) Gateway — No Gateway 

b. Highlight the next controller and configure the IP protocol with the 
following information. Click IPX to select it. and then click Next. 

1) Address — 172.20.100.1 

2) Mask — 255.255.255.0 

3) Gateway — No Gateway 

4. For node 2: 

a. Highlight the Compaq NetFlex Controller and configure the IP protocol 
with the following information. Click IPX to select it, and then click 
Next. 

1) Address — 172.20.10.2 

2) Mask — 255.255.255.0 

3) Gateway — No Gateway 

b. Highlight the next controller and configure the IP protocol with the 
following information. Click IPX to select it, and then click Next. 

1) Address — 172.20.100.2 

2) Mask — 255.255.255.0 

3) Gateway — No Gateway 

5. Select the appropriate time zone and daylight savings time information for 
your area in the Time Zone screen and click Next. 
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Installing NDS 

  
1. Select Create New NDS Tree → Next for node 1. 

2. Select Install this server into an existing NDS tree → Next for node 2. 

3. Enter LAB_TREE in the Tree Name field. 

 
 

4. Enter TRNG.COMPAQ for server object context in the Context for Server 
Object field. 
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5. Click in the Admin Context field. The Admin context defaults to the server 
context. 

6. In the Administrator Login field: 

a. For node 1 enter and confirm the admin password as password. 

b. For node 2, select browse and open folders until the admin user 
displays. Click OK to return to the NDS screen, and then enter the 
password as password. 

7. Select Next. 
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8. Confirm NDS configuration by selecting Next. The License screen displays. 

  
9. Insert the license diskette or browse through the drop-down menu to enter the 

path to the license file (*.nlf). 

10. Select Next to confirm license and proceed to the next step. 
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Installing Additional Products and Services 

  
1. Review the Novell products available for installation with NetWare. List 

those that would be of interest to your environment. Notice that by default, 
the following additional products from Compaq are selected for installation 
(you must scroll down the list to see the Compaq products): 

a. Compaq Support Software for Novell Products 

b. Compaq Integration Maintenance Utility 

c. Compaq Management Agents for Servers 

d. Compaq Survey Utility 

2. Select Next. The NSSD options screen displays a list of additional utilities 
from Compaq Support Software for Novell Products. Choose all of the 
options available from the selection screen. These can include: 

a. Compaq Server Health Support Driver 

b. Compaq Online Configuration Utility 

c. Compaq Integrated Management Log Viewer 

d. Compaq Remote Insight Management Agent 

e. Compaq Recovery Server Option 

f. Compaq Power Supply Utility 

g. Novell Support Software from Compaq Update Utility 
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3. Select Next. PCI Hot Plug is configurable at this time.  

4. Select Enable PCI Hot Plug if your system supports PCI Hot Plug. If not, 
select Next. 

5. Select each option and click Next to continue. 

6. Accept the default community strings by selecting Next in the SNMP 
Parameter configuration screen. A summary screen displays for your review.  

7. Select Finish. NetWare will begin a file copy of the selected products. 

8. Insert the SmartStart CD when prompted. 

9. Insert the Management CD when prompted. 
 
 Note 

If the either of the CDs is not recognized as being the correct one, click the 
browse icon, close the root folder, reopen the root folder, open the local files 
folder, select the CD and then click OK. 

 
10. Click OK at the message “The installation of NetWare…” 

11. Remove all media from the drives when prompted. 

12. Click Yes to restart the computer when prompted. 

  
If this was node 2, your SmartStart installation of NetWare installation is 
complete. 
 

! Important 
Before proceeding to the NetWare Cluster Services (NWCS) lab, ensure to 
install NetWare Service Pack 3a or Service Pack 4 on both nodes. Service 
Pack 3a is required for NWCS. Other applications might require additional 
Service packs-installations. See your application documentation for specific 
details. 
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Exercise 4 — Replacing a Failed Controller 
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CL1850 Cluster Single Controller  

1. Connect the Windows 95/98/NT system to the port labeled Controller 1 on 
the back of the shared storage area using a serial cable. Power down the 
failed controller. 

2. Remove the failed controller. 

3. Insert the new controller. 

4. Select Start → Compaq Utilities → CR3500 Configuration Utility. 

5. Select Controller → Configuration → Restore from the Storage pull-down 
menu. 

 

!  
Warning 
When restoring a configuration, the configuration being restored must exactly 
match the current hardware configuration. 
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Exercise 5 — Upgrading From a Single to a Dual Controller 
Configuration 
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CL1850 Cluster Dual Controller  

1. Connect the Windows 95/98/NT system to the port labeled Controller 1 on 
the back of the shared storage area using a serial cable. Start the CR3500 
Configuration Utility. 

2. Save the existing configuration. From the Storage pull-down menu, select 
Controller → Configuration → Save. 

3. Suspend all I/O and power down the shared storage subsystem. 

4. Install the second controller in the bottom controller slot of the shared storage 
subsystem. 

5. Power up the shared storage subsystem. 

6. Restore the controller configuration settings. From the Storage pull-down 
menu, select Controller → Configuration → Restore. 
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